POJ 1230 Pass-Muraille

POJ 1230


Pass-Muraille
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9454 Accepted: 2934

Description

In modern day magic shows, passing through walls is very popular in which a magician performer passes through several walls in a predesigned stage show. The wall-passer (Pass-Muraille) has a limited wall-passing energy to pass through at most k walls in each wall-passing show. The walls are placed on a grid-like area. An example is shown in Figure 1, where the land is viewed from above. All the walls have unit widths, but different lengths. You may assume that no grid cell belongs to two or more walls. A spectator chooses a column of the grid. Our wall-passer starts from the upper side of the grid and walks along the entire column, passing through every wall in his way to get to the lower side of the grid. If he faces more than k walls when he tries to walk along a column, he would fail presenting a good show. For example, in the wall configuration shown in Figure 1, a wall-passer with k = 3 can pass from the upper side to the lower side choosing any column except column 6. 

Given a wall-passer with a given energy and a show stage, we want to remove the minimum number of walls from the stage so that our performer can pass through all the walls at any column chosen by spectators. 

Input

The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains two integers n (1 <= n <= 100), the number of walls, and k (0 <= k <= 100), the maximum number of walls that the wall-passer can pass through, respectively. After the first line, there are n lines each containing two (x, y) pairs representing coordinates of the two endpoints of a wall. Coordinates are non-negative integers less than or equal to 100. The upper-left of the grid is assumed to have coordinates (0, 0). The second sample test case below corresponds to the land given in Figure 1. 

Output

There should be one line per test case containing an integer number which is the minimum number of walls to be removed such that the wall-passer can pass through walls starting from any column on the upper side. 

Sample Input

2
3 1
2 0 4 0
0 1 1 1
1 2 2 2
7 3
0 0 3 0
6 1 8 1
2 3 6 3
4 4 6 4
0 5 1 5
5 6 7 6
1 7 3 7

Sample Output

1
1

Hint

Walls are parallel to X.

Source


题意:

魔术师前方有 n 堵墙,而他每次最多能跳过 k 堵墙,求拆掉最少的墙,使他在任意列都能一次跳过所有的墙。

贪心,从左向右遍历当前列的墙的个数,假设当前列的墙数超过了 k 堵,拆,开始想的把在当前列的长度最大的墙拆了

后来想想,当前列前面的墙无论多长都没有什么影响,所以,

每次选择所在当前列的墙中右端点最大的删除,这样才能对后面的影响最小,

使后面拆的墙数最少,为最优方案。


代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
struct wall
{
    int x1, y1, x2, y2, ok; //ok记录墙是否拆了,1表示未拆,0表示拆了
} W[110];

int main()
{
    int t, n, k;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d%d", &n, &k);
        int mx = 0;             //记录所有墙的最右端点
        for(int i = 0; i < n; i++)
        {
            scanf("%d%d%d%d", &W[i].x1, &W[i].y1, &W[i].x2, &W[i].y2);
            if(W[i].x1 > W[i].x2) swap(W[i].x1, W[i].x2);   //刚开始没写,坑我WA一次
            W[i].ok = 1;                    //标记所有的墙都未拆
            mx = max(mx, W[i].x2);
        }
        int sum = 0;
        for(int i = 0; i <= mx; i++)    //判断点 i 所在列有几堵墙
        {
            int cnt = 0;
            for(int j = 0; j < n; j++)
                if(i >= W[j].x1 && i <= W[j].x2 && W[j].ok == 1) cnt++;
            if(cnt <= k) continue;      //墙数不超过k,继续判断下一列
            cnt -= k;        //删除 cnt 个墙
            sum += cnt;
            while(cnt--)
            {
                int End = 0, id = 0;        //贪心,这里删除满足条件的右端点最大的墙
                for(int k = 0; k < n; k++)
                    if(W[k].ok == 1 && i >= W[k].x1 && i <= W[k].x2 && W[k].x2 > End)
                    {
                        id = k;
                        End = W[k].x2;
                    }
                W[id].ok = 0;
            }
        }
        printf("%d\n", sum);
    }
    return 0;
}



POJ 3213 题目是一个关于矩阵乘法的经典计算机科学问题。矩阵乘法通常是线性代数的基础操作,给定两个矩阵 A 和 B,你需要计算它们的乘积 C = A * B,其中每个元素 C[i][j] 是对应位置上 A 的行向量与 B 的列向量的点积。 以下是一个简单的 Java 代码示例,使用嵌套循环来实现矩阵乘法: ```java import java.util.Scanner; public class MatrixMultiplication { public static void main(String[] args) { Scanner scanner = new Scanner(System.in); // 输入矩阵的维度 System.out.println("Enter the dimensions of matrix A (m x n):"); int m = scanner.nextInt(); int n = scanner.nextInt(); // 创建矩阵 A 和 B int[][] matrixA = new int[m][n]; int[][] matrixB = new int[n][n]; // 读取矩阵 A 的元素 System.out.println("Enter elements of matrix A:"); for (int i = 0; i < m; i++) { for (int j = 0; j < n; j++) { matrixA[i][j] = scanner.nextInt(); } } // 读取矩阵 B 的元素(假设输入的矩阵都是方阵,大小为 n x n) System.out.println("Enter elements of matrix B:"); for (int i = 0; i < n; i++) { for (int j = 0; j < n; j++) { matrixB[i][j] = scanner.nextInt(); } } // 矩阵乘法 int[][] result = new int[m][n]; // 结果矩阵 for (int i = 0; i < m; i++) { for (int j = 0; j < n; j++) { for (int k = 0; k < n; k++) { // 每次循环k用于遍历B的列 result[i][j] += matrixA[i][k] * matrixB[k][j]; } } } // 输出结果矩阵 System.out.println("Matrix multiplication result:"); for (int[] row : result) { for (int element : row) { System.out.print(element + " "); } System.out.println(); } scanner.close(); } } ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值