02-线性结构3 Reversing Linked List (25分)
Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.
Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10
5
) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address is the position of the node, Data is an integer, and Next is the position of the next node.
Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
题目大意:反转单链表,给定常数K和单链表L,要求按每K个节点反转单链表,如:L: 1->2->3->4->5->6 K=3,输出:3->2->1->6->5->4,如果K=4,输出:4->3->2->1->5->6.
输入说明:每次输入一个案例,对每个案例,第一行内容是链表第一个节点的地址,节点数N(N<=100,000)(不一定是最终形成的单链表的节点数),常数K(<=N),K是需要反转的子链表的长度,节点的地址是一个5位的非负整数,NULL用-1来代替。
下面输入N行 格式如下:
Address Data Next
Address代表节点的位置,Data是整型数字,Next是下一个节点的位置。
输出说明:输出反转后的单链表,每个节点占一行,格式和输入的一样。
#include <iostream>
#include <stack>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
const int maxn = 100005;
struct node
{
int val, next;
} nt[maxn];
int point[maxn];
int main()
{
int first, n, k;
int a, b, c;
cin >> first >> n >> k;
for (int i = 0; i < n; i++)
{
cin >> a >> b >> c;
nt[a].next = c;
nt[a].val = b;
}
int p = first;
int cnt = 0;
while (p != -1)
{
point[cnt++] = p;
p = nt[p].next;
}
int i = 0;
while (i + k <= cnt)
{
reverse(&point[i], &point[i + k]);
i = i + k;
}
for (i = 0; i < cnt - 1; i++)
{
printf("%05d %d %05d\n", point[i], nt[point[i]].val, point[i + 1]);
}
printf("%05d %d -1\n", point[i], nt[point[i]].val);
return 0;
}