hdu1394——Minimum Inversion Number


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

Author
CHEN, Gaoli
 

Source


树状数组求逆序数,也可以线段树和归并排序

1.求逆序数,
2循环移动后,各个序列之间逆序的关系

比如没移动的时候,有x个,移动a[0]到最后,那么现在就是     x-a[0]+n-a[0]-1  (因为这些数的大小是0~n-1,所以第一个数产生的逆序数就是这个数本身的大小,那么移动后新产生的逆序数就是n-1-这个数了

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

int tree[5010];
int val[5010];
int n;
inline int lowbit(int x)
{
	return x&(-x);
}

void add(int x,int val)
{
	for(int i=x;i<=5010;i+=lowbit(i))
		tree[i]+=val;
}

int sum(int x)
{
	int ans=0;
	for(int i=x;i;i-=lowbit(i))
		ans+=tree[i];
	return ans;
}


int main()
{
	while(~scanf("%d",&n))
	{
		int ans=0,cnt=0;
		memset(tree,0,sizeof(tree));
		for(int i=1;i<=n;i++)
			scanf("%d",&val[i]);
		for(int i=1;i<=n;i++)
		{
			add(val[i]+1,1);
			ans+=i-sum(val[i]+1);
		}
		cnt=ans;
		for(int i=1;i<=n-1;i++)
		{
			cnt=cnt-val[i]+n-val[i]-1;
			ans=min(cnt,ans);
		}
		printf("%d\n",ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值