uva 674 - Coin Change

本文介绍了一种解决硬币找零问题的算法实现,通过动态规划的方法找出特定金额下使用5种不同面额硬币的所有可能组合数。该算法能够处理高达7489美分的金额,并附带了一个C语言程序示例。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >


  Coin Change 

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.


For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.


Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

Input 

The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

Output 

For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

Sample Input 

11
26

Sample Output 

4
1
#include<stdio.h>
#include<string.h>
#define max 7489
int a[max+1][5],b[5]={5,10,25,50};
int main()
{
 int i,j,x;
 for (i=1;i<=max;i++)
 a[i][0]=1;
 for (i=0;i<4;i++)
 {
  for (j=1;j<=max;j++)
  if (j<b[i]) a[j][i+1]=a[j][i];
         else if (j==b[i]) a[j][i+1]=a[j][i]+1;
                else       a[j][i+1]=a[j-b[i]][i+1]+a[j][i];
 }
 while (scanf("%d",&x)!=EOF)
 printf("%d\n",a[x][4]);
 return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值