uva 10341 - Solve It

本文介绍如何解决一个特定形式的数学方程,并通过编程实现找到方程在指定区间内的解,输出精确到小数点后四位的结果,或者在没有解的情况下输出'Nosolution'。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Problem F

Solve It

Input: standard input

Output: standard output

Time Limit: 1 second

Memory Limit: 32 MB

Solve the equation:
        p*e-x + q*sin(x) + r*cos(x) + s*tan(x) + t*x2 + u = 0
        where 0 <= x <= 1.

Input

Input consists of multiple test cases and terminated by an EOF. Each test case consists of 6 integers in a single line: p, q, r, s, t and u (where 0 <= p,r <= 20 and -20 <= q,s,t <= 0). There will be maximum 2100 lines in the input file.

Output

For each set of input, there should be a line containing the value of x, correct upto 4 decimal places, or the string "No solution", whichever is applicable.

Sample Input

0 0 0 0 -2 1
1 0 0 0 -1 2
1 -1 1 -1 -1 1

Sample Output

0.7071
No solution
二分法零点定理找根,必须在[0,1]上单调,
求导f'(x)=-p*e(-x)+q*cos(x)-r*sin(x)+s/(cos(x)*cos(x))+2t*x
x      , [0,1]
e(-x) ,[1/e,1]
cos(x),[0,pi]
sin(x) , [0,pi]
p,r>0 q,s,t<0, f'(x)的每一项都是负的,
f(x)单调递减
#include<string.h>
#include<stdio.h>
#include<math.h>
double p,q,r,s,t,u;
double ans(double x)
{return p*exp(-x)+q*sin(x)+r*cos(x)+s*tan(x)+t*x*x+u;};
double answer,f;
void find(double left,double right)
{
 double mid=(left+right)/2,k1,k2,k3;
 if ((f>0)||(left-right>=1e-6)) return;
 k1=ans(left);
 k2=ans(mid);
 k3=ans(right);
 if (k1*k3>0) return ;
 if (fabs(k1)<1e-6) {answer=left;f=1;return;}
 if (fabs(k3)<1e-6) {answer=right;f=1;return;}
 if (fabs(k2)<1e-6) {answer=mid;f=1;return;}
 if (k1*k2<0) find(left,mid);
 if (k2*k3<0) find(mid,right);
}
int main()
{
 while (scanf("%lf%lf%lf%lf%lf%lf",&p,&q,&r,&s,&t,&u)!=EOF)
 {
  f=-1;
  find(0,1);
  if (f>0) printf("%.4lf\n",answer);
    else printf("No solution\n");
 }
 return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值