PAT:A1031 Hello World for U (20 分)
Given any string of N (≥5) characters, you are asked to form the characters into the shape of U
. For example, helloworld
can be printed as:
h d
e l
l r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U
to be as squared as possible -- that is, it must be satisfied that n1=n3=max { k | k≤n2 for all 3≤n2≤N } with n1+n2+n3−2=N.
Input Specification:
Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.
Output Specification:
For each test case, print the input string in the shape of U as specified in the description.
Sample Input:
helloworld!
Sample Output:
h !
e d
l l
lowor
代码:
C/C++:
#include<stdio.h>
#include<string.h>
int main() {
char str[1010];
gets(str);
int len = strlen(str);
int a[10] = {0};
for(int i = 0; i < len; i++) {
a[str[i] - '0']++;
}
for(int i = 0; i < 10; i++) {
if(a[i] != 0) printf("%d:%d\n", i, a[i]);
}
return 0;
}
Java:
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner in = new Scanner(System.in);
String str;
str = in.nextLine();
int len = str.length();
int N1 = (len + 2) / 3;
int N3 = N1, N2 = len + 2 - 2 * N1;
for (int i = 0; i < N1 - 1; i++) {
System.out.print(str.charAt(i));
for(int j = 0; j < N2 - 2; j++) {
System.out.print(" ");
}
System.out.println(str.charAt(len - i - 1));
}
for(int i = 0; i < N2; i++) {
System.out.print(str.charAt(N1 - 1 + i));
}
}
}