HDU1087 Super Jumping! Jumping! Jumping! 最大上升子序列的和

本文介绍了一款名为“SuperJumping”的棋盘游戏,玩家需从起点跳跃至终点,途中经过的棋子数值累加为得分。文章通过动态规划算法求解游戏中的最大得分路径。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 53697 Accepted Submission(s): 24932

Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output
For each case, print the maximum according to rules, and one line one case.

Sample Input
3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output
4
10
3

问题连接

问题描述

棋盘上有一些棋子,用“start”,“end”和正整数表示,游戏规则是:从“start”起,最终跳到“end”,从小的数位置可以跳到大的数的位置,但不能返回,每落到一个有分数的位置就加上对应分数。要求输出一局游戏能获得的最大分数。

问题分析

最大上升子序列问题。dp[i]表示从起始点到第i个带分数的棋子所能获得的最大分数,v[i]表示第i个棋子的数值。取j<i,如果v[i]>v[j],则说明能从第j个棋子跳到第i个棋子,就进行dp,那么最后得到的dp[i]就是到各个位置所能获得的最大分数,取其中最大的那个就是答案了。

c++程序如下

#include<iostream>
#include<cstdio>
using namespace std;
typedef long long LL;
const int N=1005;
LL dp[N],v[N];
LL max(LL a,LL b)
{
	return a>b?a:b;
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF&&n)
	{
		int i;
		for(i=1;i<=n;i++)//输入
		{
			scanf("%d",v+i);
			dp[i]=v[i];
		}
		for(i=1;i<=n;i++)
		{
			for(int j=i-1;j>0;j--)
				if(v[i]>v[j]) dp[i]=max(dp[i],dp[j]+v[i]);
		}//dp
		long long ans=0;
		for(i=1;i<=n;i++)
		ans=max(ans,dp[i]);
		printf("%lld\n",ans); 
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值