D - Five, Five Everywhere
Time limit : 2sec / Memory limit : 256MB
Score: 400 points
Problem Statement
Print a sequence a1,a2,…,aN whose length is N that satisfies the following conditions:
- ai (1≤i≤N) is a prime number at most 55 555.
- The values of a1,a2,…,aN are all different.
- In every choice of five different integers from a1,a2,…,aN, the sum of those integers is a composite number.
If there are multiple such sequences, printing any of them is accepted.
Notes
An integer N not less than 2 is called a prime number if it cannot be divided evenly by any integers except 1 and N, and called a composite number otherwise.
Constraints
- N is an integer between 5 and 55 (inclusive).
Input
Input is given from Standard Input in the following format:
N
Output
Print N numbers a1,a2,a3,…,aN in a line, with spaces in between.
Sample Input 1
5
Sample Output 1
3 5 7 11 31
Let us see if this output actually satisfies the conditions.
First, 3, 5, 7, 11 and 31 are all different, and all of them are prime numbers.
The only way to choose five among them is to choose all of them, whose sum is a1+a2+a3+a4+a5=57, which is a composite number.
There are also other possible outputs, such as 2 3 5 7 13
, 11 13 17 19 31
and 7 11 5 31 3
.
Sample Input 2
6
Sample Output 2
2 3 5 7 11 13
- 2, 3, 5, 7, 11, 13 are all different prime numbers.
- 2+3+5+7+11=28 is a composite number.
- 2+3+5+7+13=30 is a composite number.
- 2+3+5+11+13=34 is a composite number.
- 2+3+7+11+13=36 is a composite number.
- 2+5+7+11+13=38 is a composite number.
- 3+5+7+11+13=39 is a composite number.
Thus, the sequence 2 3 5 7 11 13
satisfies the conditions.
Sample Input 3
8
Sample Output 3
2 5 7 13 19 37 67 79
冥思苦想1小时,想着暴力,想着贪心,却没有直觉的发现5个数字和为合数的特殊情况,到底是什么情况才能使得我们不确定的数字加起来都为和数呢,而且这些数字我们是知道的,有5000+个,从里面跳出来50个可以使得任意加起来为合数。
就是末尾数字一样,成为5的倍数。素数里面5,2有点特殊,有很多方面可以考虑,这些智力题目,下次就得多考虑一下。。
想清楚了,代码就很弱智了。
#include <iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#define LL long long
using namespace std;
const int maxn=56;
const int MAXN=330000;
int prime[MAXN];//保存素数
bool vis[MAXN];//初始化
int ans[66];
int Prime(int n)
{
int cnt=0;
memset(vis,0,sizeof(vis));
for(int i=2;i<n;i++)
{
if(!vis[i])
prime[cnt++]=i;
for(int j=0;j<cnt&&i*prime[j]<n;j++)
{
vis[i*prime[j]]=1;
if(i%prime[j]==0)//关键
break;
}
}
return cnt;//返回小于n的素数的个数
}
int main()
{
Prime(55556);
int n;
cin>>n;
int cnt=1;
cout<<11;
for(int i=6;i<5300;i++){
if( cnt<n && prime[i]%10 == 1){
cnt++;
cout<<" "<<prime[i];
}
}
cout<<endl;
}