How many prime numbers
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 16170 Accepted Submission(s): 5578
Problem Description
Give you a lot of positive integers, just to find out how many prime numbers there are.
Input
There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.
Output
For each case, print the number of prime numbers you have found out.
Sample Input
3 2 3 4
Sample Output
2
Author
wangye
Source
这道题=.=
很好很水很神奇。
他说在32位以内,数太大了打表肯定不行。然后这题可以直接判定素数暴力过……
#include<stdio.h>
#include<string.h>
#include<math.h>
int main()
{
int n;
int i,j,a;
while(~scanf("%d",&n))
{
int ans=0,flag=0;
for(i=0;i<n;i++)
{
scanf("%d",&a);
for(j=2;j<=sqrt(1.0*a);j++)
{
if(a%j==0)
{
flag=1;
break;
}
}
if(!flag)
ans++;
flag=0;
}
printf("%d\n",ans);
}
return 0;
}