POJ 3268 Silver Cow Party 最短路 dij

本文介绍了一种解决N个农场中每头牛前往特定聚会地点并返回原农场的最短时间问题的方法。利用单源最短路径算法DIJ两次分别计算前往聚会地点和返回的最短时间,最终确定所有牛中最长的往返时间。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤XN). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; roadi requiresTi (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

题意:第一行给出N个点 M条单向路径 以及终点位置  每个点(起点)都有一头牛要去终点 
下面给出所有单向路径的起点 终点 和消耗时间  求所有牛(到达终点 再返回起点的最短时间)中的最长时间。

思路:
每个起点到终点的最短时间(多源) 可理解为终点到所有点的最短时间(单源) DIJ即可
而返回 也可以通过 改变所有路径的方向  再求终点到所有点的最短路  

代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define mm  1005
#define maxx  0x3f3f3f3f
using namespace std;
int map[mm][mm];
int vis[mm],back_vis[mm];
int dis[mm],back_dis[mm];
int m,n,k;
void dij()
{
    int i,j,pos,minn;
    for(i=1; i<=m; i++)
    {
        vis[i]=0;
        dis[i]=map[k][i];
    }
    vis[k]=1;
    for(i=1; i<m; i++)
    {
        minn=maxx;
        for(j=1; j<=m; j++)
        {
            if(!vis[j]&&dis[j]<minn)
            {
                minn=dis[j];
                pos=j;
            }
        }
        vis[pos]=1;
        for(j=1; j<=m; j++)
        {
            if(!vis[j]&&dis[pos]+map[pos][j]<dis[j])
                dis[j]=dis[pos]+map[pos][j];
        }
    }

    for(i=1; i<=m; i++)
    {
        back_vis[i]=0;
        back_dis[i]=map[i][k]; //  换种理解(反向道路才能走)
    }
    back_vis[k]=1;
    for(i=1; i<m; i++)
    {
        minn=maxx;
        for(j=1; j<=m; j++)
        {
            if(!back_vis[j]&&back_dis[j]<minn)
            {
                minn=back_dis[j];
                pos=j;
            }
        }
        back_vis[pos]=1;
        for(j=1; j<=m; j++)
        {
            if(!back_vis[j]&&back_dis[pos]+map[j][pos]<back_dis[j])
                back_dis[j]=back_dis[pos]+map[j][pos];
        }
    }
}
int main()
{
    int i,j;
    while(~scanf("%d%d%d",&m,&n,&k))
    {
        for(i=1; i<=m; i++)
            for(j=i; j<=m; j++)
            {
                if(i!=j)
                map[i][j]=map[j][i]=maxx;
                else
                    map[i][j]=0;         //自己和自己的距离为0  
            }
        int a,b,t;
        while(n--)
        {
            scanf("%d%d%d",&a,&b,&t);
            map[a][b]=t;
        }
        dij();
        int maxxx=0;
        for(i=1; i<=m; i++)
        {
            if(dis[i]+back_dis[i]>maxxx)
                maxxx=dis[i]+back_dis[i];
        }
        cout<<maxxx<<endl;
    }
    return 0;
}
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值