Description
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
Figure A Sample Input of Radar Installations
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations
Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.
The input is terminated by a line containing pair of zeros
The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2 1 2 -3 1 2 1 1 2 0 2 0 0
Sample Output
Case 1: 2 <p>Case 2: 1</p>
题意 :有n个小岛 并给出海岸线上雷达覆盖的半径d,雷达只能放置于海岸线上(x轴),给出每个小岛的坐标,问至少要多少个雷达才能把小岛全部覆盖。
代码:
#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
struct node{
double l,r;
}q[1002];
bool cmp(node a,node b)
{
return a.r<b.r;
}
int main()
{
int m,n,a,b,i,t,k=0,s;
while(cin>>m>>n)
{
k++;
t=0;
if(m==0&&n==0)
break;
s=1;
for(i=0;i<m;i++)
{
cin>>a>>b;
if(b>n) //如果某岛y值大于半径 一定不能覆盖
t=1;
q[i].l=a-sqrt((double)n*n-b*b);
q[i].r=a+sqrt((double)n*n-b*b); //求出每个岛要被覆盖 能放置的雷达区域
}
if(t==1)
{
cout<<"Case "<<k<<": -1"<<endl;
continue;
}
sort(q,q+m,cmp); //关于右端排序
double ld=q[0].r;
for(i=1;i<m;i++)
{
if(q[i].l>ld)
{
s++;
ld=q[i].r;
}
else if(q[i].r<ld)
ld=q[i].r;
}
cout<<"Case "<<k<<": "<<s<<endl;
}
return 0;
}
将每个小岛的能安置的雷达区间求出来,然后对每个区间的右端点按从小到大排序,将第一个雷达放在第一个区间的右端点,然后对下一个区间进行判断: 1.如果下一个区间的左端点在雷达的右边,那么雷达一定不能覆盖到下一个岛屿,雷达数加1,将新雷达放置在下一个区间的右端点 2.如果下一个区间的右端点在雷达的左边,那么雷达能够覆盖,将雷达放置到下一个区间的右端点 3.如果下一个区间的左端点在雷达的左边,右端点在雷达的右边,即两个区间相交,那么雷达能覆盖下一个岛屿,雷达位置不变 注意用double处理