Fibonacci
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 18002 | Accepted: 12515 |
Description
In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:
0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is
.
Given an integer n, your goal is to compute the last 4 digits of Fn.
Input
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.
Output
For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).
Sample Input
0
9
999999999
1000000000
-1
Sample Output
0
34
626
6875
Hint
As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by
.
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:
这道题用的快速幂,需要求矩阵乘法最高有1,000,000次。用快速幂时间复杂度log2N。矩阵乘法的使用需要对矩阵有一定的认识和对线性代数本质的理解。
#include<stdio.h>
#include<string.h>
long long n;
const int N=2;
int t[N][N];
void matrixm(int a[][N],int b[][N]){
int i,j,k,temp[N][N];
memset(temp,0,sizeof(temp));
for(i=0;i<N;i++)
for(j=0;j<N;j++)
for(k=0;k<N;k++)
temp[i][j]+=a[i][k]*b[k][j];
for(i=0;i<N;i++)
for(j=0;j<N;j++)
b[i][j]=temp[i][j]%10000;
}
int main(){
int a[N][N],i,j;
while(scanf("%lld",&n)){
if(n==-1)
break;
t[0][0]=1; //t是行列式为1的矩阵
t[0][1]=0;
t[1][0]=0;
t[1][1]=1;
a[0][0]=1; //a是标准模式矩阵
a[0][1]=1;
a[1][0]=1;
a[1][1]=0;
while(n){
if(n&1==1)
matrixm(a,t);
matrixm(a,a);
n/=2;
}
printf("%d\n",t[0][1]);
}
return 0;
}
这一道题中,可以注意一下const int N。 N在c语言中是不可以用来定义数组长度的比如a[N][N],但是c++中是允许的。