Problem Description
给你一个由大写字母组成的组成的字符串,你可以用如下规则对其进行编码:
1、 包含K个相同字母的连续字符串可以用KX表示,其中X是相同的字母。
2、 如果K为1,不输出K
Input
输入有多组,直到文件结束。每组一个字符串,长度为10000以内
Output
输出编码后的字符串。
Sample Input
ABC ABBCCC
Sample Output
ABC A2B3C
Hint
Source
lin
import java.util.*;
public class Main {
public static void main(String args[]){
Scanner cin = new Scanner(System.in);
while(cin.hasNext()){
String s = cin.next();
char a[] = s.toCharArray();
int i, j;
for(i = 0; i < a.length;){
int t = 1;
for(j = i + 1; j < a.length; j++){
if(a[j] == a[i]){
t++;
}
else{
break;
}
}
if(t != 1){
System.out.print(t);
System.out.print(a[i]);
}
else if(t == 1){
System.out.print(a[i]);
}
i = j;
}
System.out.print("\n");
}
}
}