1046 Shortest Distance(20 分)
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,105]), followed by N integer distances D1 D2 ⋯ DN, where Diis the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.
Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7
#include <iostream>
#include <algorithm>
using namespace std;
int main()
{
int n;
int dist[100010];
int sum = 0;
int m;
scanf("%d", &n);
for(int i = 1; i <= n; i++){
scanf("%d", &dist[i]);
sum += dist[i];
dist[i] = sum; //dist[i]累加,避免之后重复计算导致超时
}
scanf("%d", &m);
int d1, d2;
for(int i = 1; i <= m; i++){
scanf("%d%d", &d1, &d2);
if(d1 > d2) swap(d1,d2);
int ans = dist[d2-1] - dist[d1-1];
printf("%d\n", min(ans, sum - ans));
}
return 0;
}