There are a group of students. Some of them may know each other, while others don’t. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.
Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don’t know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.
Calculate the maximum number of pairs that can be arranged into these double rooms.
Input
For each data set:
The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.
Proceed to the end of file.
Output
If these students cannot be divided into two groups, print “No”. Otherwise, print the maximum number of pairs that can be arranged in those rooms.
Sample Input
4 4
1 2
1 3
1 4
2 3
6 5
1 2
1 3
1 4
2 5
3 6
Sample Output
No
3
题意:
是有n个学生,有m对认识的,每一对认识的要分到一间房间。
首先让你判断这些学生是否是二分图,即一共有两组,要求每组的学生都互不认识。
如果能分成两组,求最多需要多少个房间。
首先要判断是否为二分图,用到的方法是染色法。
首先取一个点(一般我们就选取第一个点)染成黑色,然后将其相邻的点染成白色,如果发现有相邻且同色的点,可知这个图并非二分图。如果是二分图,再求其最大匹配数。
参考博客:
染色法判定二分图1
染色法判定二分图2
算法讲解:二分图匹配
代码:
#include<stdio.h>
#include<string.h>
using namespace std;
int map[207][207];//无向图,该数组用来储存可以相互连通的边
int color[207];//color用来记录i~n这n个点的颜色
int link[207];//link是用来记录j和i匹配。
//例:link[j]=i,则说明j和i进行匹配。link[j]=0,说明,此时j没有被匹配
bool vis[207];//vis数组是用来标记某个点已经被匹配
bool flag;//用来标记是否为二分图
int n,m;//n个顶点,m个关系
//染色法判定二分图
void dfs(int i,int col)//深搜,递归。第i个点的颜色为col ,一层一层的染
{
for(int j=1; j<=n; j++)
{
if(map[i][j])//如果有这条边 i~j,即j是i的子节点
{
if(!color[j])//j节点没有被染上颜色
{
color[j]=-col;//把j(子节点)的颜色与i(父节点)的颜色染成相反的颜色
dfs(j,color[j]);//从j(子节点 )开始往下找 ,即给下一层染上颜色
}
else if(color[j]==col)//如果下一个点(j)(子节点)的颜色和这个点(i)(父节点)颜色相同;
//即,发生冲突,说明就不是最大匹配
{
flag=false;
return;
}
if(flag==false)
return ;
}
}
return ;//可以不用加return ; 不加就自动返回
}
bool check()
{
flag=true;
color[1]=1;//颜色1代表黑色,-1代表白色。从第一个点开始找
dfs(1,1);
return flag;
}
//二分图的最大匹配
bool find(int i)
{
for(int j=1; j<=n; j++)
if(map[i][j]&&!vis[j])//此时i和j连通,j没有被标记
{
vis[j]=true;//把j标记
if(link[j]==0||find(link[j]))//link[j]没有被配对;
//或link[j]被配对,所以我们要找link[j]是否有“备胎 ”
{
link[j]=i;
return true;
}
}
return false;
}
int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
memset(map,0,sizeof(map));
memset(color,0,sizeof(color));
memset(link,0,sizeof(link));
int a,b,ans=0;
for(int i=0; i<m; i++)
{
scanf("%d%d",&a,&b);
map[a][b]=map[b][a]=1;//储存图
}
if(!check())//判断是不是二分图
{
printf("No\n");
continue;
}
for(int i=1; i<=n; i++) //求最大匹配数
{
memset(vis,false,sizeof(vis));
if(find(i))
ans++;
}
//ans要除以2。例:1和4配对,ans加1;4和1配对,ans加1;相当于加了两次。
printf("%d\n",ans/2);
}
return 0;
}