Dirichlet's Theorem on Arithmetic Progressions
Description If a and d are relatively prime positive integers, the arithmetic sequence beginning with a and increasing by d, i.e., a, a + d, a + 2d, a + 3d, a + 4d, ..., contains infinitely many prime numbers. This fact is known as Dirichlet's Theorem on Arithmetic Progressions, which had been conjectured by Johann Carl Friedrich Gauss (1777 - 1855) and was proved by Johann Peter Gustav Lejeune Dirichlet (1805 - 1859) in 1837. For example, the arithmetic sequence beginning with 2 and increasing by 3, i.e.,
contains infinitely many prime numbers
Your mission, should you decide to accept it, is to write a program to find the nth prime number in this arithmetic sequence for given positive integers a, d, and n. Input The input is a sequence of datasets. A dataset is a line containing three positive integers a, d, and n separated by a space. a and d are relatively prime. You may assume a <= 9307, d <= 346, and n <= 210. The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset. Output The output should be composed of as many lines as the number of the input datasets. Each line should contain a single integer and should never contain extra characters. The output integer corresponding to a dataset a, d, n should be the nth prime number among those contained in the arithmetic sequence beginning with a and increasing byd. FYI, it is known that the result is always less than 106 (one million) under this input condition. Sample Input 367 186 151 179 10 203 271 37 39 103 230 1 27 104 185 253 50 85 1 1 1 9075 337 210 307 24 79 331 221 177 259 170 40 269 58 102 0 0 0 Sample Output 92809 6709 12037 103 93523 14503 2 899429 5107 412717 22699 25673 Source |
这道题倒是没啥可说的,唯一要注意的就是打素数表一定要用筛法!!
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <cstring>
#include <map>
#include <string>
#include <stack>
#include <cctype>
#include <vector>
#include <queue>
#include <set>
#include <utility>
#include <cassert>
using namespace std;
///#define Online_Judge
#define outstars cout << "***********************" << endl;
#define clr(a,b) memset(a,b,sizeof(a))
#define lson l , m , rt << 1
#define rson m + 1 , r , rt << 1 | 1
#define mk make_pair
#define FOR(i , x , n) for(int i = (x) ; i < (n) ; i++)
#define FORR(i , x , n) for(int i = (x) ; i <= (n) ; i++)
#define REP(i , x , n) for(int i = (x) ; i > (n) ; i--)
#define REPP(i ,x , n) for(int i = (x) ; i >= (n) ; i--)
const int MAXN = 1000000 + 500;
const int sigma_size = 26;
const long long LLMAX = 0x7fffffffffffffffLL;
const long long LLMIN = 0x8000000000000000LL;
const int INF = 0x7fffffff;
const int IMIN = 0x80000000;
#define eps 1e-8
const int MOD = (int)1e9 + 7;
typedef long long LL;
const double PI = acos(-1.0);
typedef double D;
typedef pair<int , int> pi;
///#pragma comment(linker, "/STACK:102400000,102400000")
int a[MAXN];
void prime_table()
{
a[0] = a[1] = 0;
FORR(i , 2 , MAXN)a[i] = 1;
FORR(i , 2 , MAXN)
{
if(a[i])
{
for(int j = 2 * i ; j <= MAXN ; j += i)
{
a[j] = 0;
}
}
}
}
int main()
{
// freopen("heritage.in","r",stdin);
// freopen("heritage.out","w",stdout);
int aa , d ,n;
prime_table();
// FOR(i , 2 , 100)cout << a[i] << ' ';
while(~scanf("%d%d%d", &aa, &d , &n) && (aa || d || n))
{
// cout << d << endl;
while(n)
{
// outstars
// cout << aa << endl;
if(a[aa])n--;
aa += d;
}
printf("%d\n" , aa - d);
}
return 0;
}
!