1046. Shortest Distance (20)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7
http://pat.zju.edu.cn/contests/pat-a-practise/1046
题意

给定在圆环上的几个点的相对位置,要求计算不同点之间的距离。

分析

简单模拟。

#include <iostream>
#define MAX 100000
int g_Dis[MAX];
int g_Sum[MAX+1];
int Min(int a,int b)
{
	if(a>b) return b;
	else return a;
}
int main ()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		int total=0;
		g_Sum[0]=0;
		for(int i=0;i<n;++i)
		{
			scanf("%d",&g_Dis[i]);
			total+=g_Dis[i];
			if(i==0)
				g_Sum[i+1]=g_Dis[i];
			else
				g_Sum[i+1]=g_Dis[i]+g_Sum[i];
		}
		int m;
		scanf("%d",&m);
		while(m--)
		{
			int a,b;
			scanf("%d%d",&a,&b);
			if(a>b)
			{
				int tmp=a;
				a=b;
				b=tmp;
			}
			int ans = g_Sum[b-1]-g_Sum[a-1];
			ans=Min(ans,total-ans);
			printf("%d",ans);
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值