A1074. Reversing Linked List (25)

本文介绍了一个算法问题:如何实现链表中每K个元素的逆序。通过输入链表节点地址、总数及逆序长度K,文章详细展示了如何读取链表数据、逆序指定长度的子链表并输出逆序后的链表。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

1074. Reversing Linked List (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
可以直接转置地址
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 1e5 + 10;
int value[maxn], nt[maxn];  //存放值的数组   下一地址数组 
int op[maxn];               //操作数组 

int main(){
	int head, n, k, address;
	scanf("%d %d %d", &head , &n, &k);
	for(int i = 0; i < n; ++i){
		scanf("%d", &address);
		scanf("%d %d", &value[address], &nt[address]);
	}
	int total = 0;
	for(int i = head; i != -1; i = nt[i]){
		op[total++] = i;
	}
	for(int i = 0; i + k <= total; i +=k){
		for(int low = i, high = low + k - 1; low < high; ++low, --high){
			swap(op[low], op[high]);
		}
	}
	for(int i = 0; i < total; ++i){
		if(i != total - 1){
			printf("%05d %d %05d\n", op[i], value[op[i]], op[i + 1]);
		}else{
			printf("%05d %d -1\n", op[i], value[op[i]]);
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值