F - Team Queue

本文介绍了一种特殊的数据结构——团队队列,它在日常生活中的应用,如午餐时段餐厅的排队情况。文章详细解释了团队队列的工作原理:当一个元素加入队列时,会先寻找同一团队的成员并紧随其后,若没有则位于队尾。通过示例输入输出展示了如何使用两个队列(成员队和团队序号队)进行团队队列的模拟,包括元素的入队和出队操作。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example.
In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue.

Your task is to write a program that simulates such a team queue.

Input
The input will contain one or more test cases. Each test case begins with the number of teams t (1<=t<=1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements.

Finally, a list of commands follows. There are three different kinds of commands:

ENQUEUE x - enter element x into the team queue
DEQUEUE - process the first element and remove it from the queue
STOP - end of test case
The input will be terminated by a value of 0 for t.

Output
For each test case, first print a line saying “Scenario #k”, where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one.
Sample Input
2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0
Sample Output
Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001
在这里要用两个队列,一个存成员,一个存成员队的序

#include <iostream>
#include <queue>
#include <cstdio>
#include <cstring>
#include <map>
#define maxn 1010

using namespace std;

int main()
{
    int kase = 0, t;

    while(scanf("%d", &t) == 1 && t) {
        printf("Scenario #%d\n", ++kase);

        queue<int> q;                       //表示由团队组成的队列
        queue<int> team_q[maxn];    //team_q[i]表示编号为i的团队的队列

         map<int, int> team;             //team[i]表示在队列中编号为i的成员所在的团队编号
        for(int i = 0; i < t; i++) {            //之所以用map容器而不直接用数组来映射的原因是用int数组可能会导致内存开销过大
            int n, x;                                   //提交到oj上会产生runtime error
            scanf("%d", &n);
            while(n--) {
                scanf("%d", &x);    //在团队中的编号为x的成员
                team[x] = i;            //将其所属团队的编号设置为i
            }
        }

        while(1) {
            char cmd[10];
            scanf("%s", cmd);

            if(cmd[0] == 'S')   break;
            else if(cmd[0] == 'E') {
                int x;
                scanf("%d", &x);
                int i = team[x];    //找到编号为x的队列成员所属的团队编号
                if(team_q[i].empty())   q.push(i);
                team_q[i].push(x);
            } else if(cmd[0] == 'D') {
                int x = q.front();      //找到队列中最前列即将出列的成员所属团队的编号
                printf("%d\n", team_q[x].front());
                team_q[x].pop();
                if(team_q[x].empty())   q.pop();    //如果出列的是该团队的最后一名成员,则在q中将整个团队pop()
            }
        }
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值