1275:小明A+B(2)
Description
小明最近多位数加法运算学的很晕倒:(,幸好是做判断题,它只需要判断A+B最后一位数是否是C就可以了,可是他真的懒的厉害,这不让你写一个程序帮助他
Input
两个长度超过100位整数A B 一个个位数C
Output
正确与否,正确是YES,错误则输出NO。
Sample Input
999999999999999999999999999999999999999999999999999999999999999999999999
88888888888888888888888888888888888888888888888
7
Sample Output
YES
#include<iostream>
#include<string>
using namespace std;
int main()
{
string A,B;
int c,count;
cin>>A>>B>>c;
count=((A[A.length()-1]-'0')+(B[B.length()-1]-'0'))%10;
if(count==c)
cout<<"YES";
else
cout<<"NO";
return 0;
}