Rank |
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) |
Total Submission(s): 2091 Accepted Submission(s): 644 |
Problem Description
Jackson wants to know his rank in the class. The professor has posted a list of student numbers and marks. Compute Jackson’s rank in class; that is, if he has the top mark(or is tied for the top mark) his rank is 1; if he has the second best mark(or is tied) his rank is 2, and so on.
|
Input
The input consist of several test cases. Each case begins with the student number of Jackson, an integer between 10000000 and 99999999. Following the student number are several lines, each containing a student number between 10000000 and 99999999 and a mark between 0 and 100. A line with a student number and mark of 0 terminates each test case. There are no more than 1000 students in the class, and each has a unique student number.
|
Output
For each test case, output a line giving Jackson’s rank in the class.
|
Sample Input
20070101 20070102 100 20070101 33 20070103 22 20070106 33 0 0 |
Sample Output
2 |
Source
2007省赛集训队练习赛(2)
|
Recommend
lcy
|
这个题比较简单;
代码:
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
typedef struct student
{
char num[9];
int rank;
}stu;
int cmp(const void* a, const void* b)
{
return ((stu*)b)->rank - ((stu*)a)->rank;
}
int main(void)
{
int i, j;
int mark, r;
char jack[9];
stu s[1000];
while(scanf("%s", jack) != EOF)
{
i = 0;
getchar();
while(scanf("%s %d", s[i].num, &(s[i].rank)) != EOF)
{
getchar();
if(atoi(s[i].num) == 0 && s[i].rank == 0)
break;
if(strcmp(jack, s[i].num) == 0)
r = s[i].rank;
i++;
}
qsort(s, i, sizeof(stu), cmp);
mark = 1;
for(j = 0;j < i;j++)
{
if(r < s[j].rank)
mark++;
else
break;
}
printf("%d\n", mark);
}
return 0;
}