Beans
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 3999 Accepted Submission(s): 1903
Problem Description
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.
Now, how much qualities can you eat and then get ?

Now, how much qualities can you eat and then get ?
Input
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.
Output
For each case, you just output the MAX qualities you can eat and then get.
Sample Input
4 6 11 0 7 5 13 9 78 4 81 6 22 4 1 40 9 34 16 10 11 22 0 33 39 6
Sample Output
242
Source
Recommend
看图意思就是求,横向的最大不连续子段和,然后得到一个数组,求这个数组的最大不连续子段和,就是相求横向然后求纵向:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[5500],i,j,k,l,m,n,s[5500],ans[5500];
int main()
{
while(scanf("%d%d",&n,&m)==2)
{
int help=0;
int x=0;
k=0;
memset(ans,0,sizeof(ans));
for(i=1;i<=n;i++)
{
int cmt=0;
int cnt=0;
memset(a,0,sizeof(a));
for(j=1;j<=m;j++)
{
scanf("%d",&a[j]);
a[j]+=cmt;
cnt=max(cnt,a[j]);//横向不连续的最大子段和
cmt=max(cmt,a[j-1]);
}
ans[i]=cnt+x;
k=max(k,ans[i]);//纵向不连续的最大子段和
x=max(x,ans[i-1]);
}
printf("%d\n",k);
}
}