杭电5590 ZYB's Biology

ZYB's Biology

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 428    Accepted Submission(s): 334


Problem Description
After getting  600  scores in  NOIP   ZYB(ZJ267)  begins to work with biological questions.Now he give you a simple biological questions:
he gives you a  DNA  sequence and a  RNA  sequence,then he asks you whether the  DNA  sequence and the  RNA  sequence are 
matched.

The  DNA  sequence is a string consisted of  A,C,G,T ;The  RNA  sequence is a string consisted of  A,C,G,U .

DNA  sequence and  RNA  sequence are matched if and only if  A  matches  U , T  matches  A , C  matches  G , G  matches  C  on each position. 
 

Input
In the first line there is the testcase  T .

For each teatcase:

In the first line there is one number  N .

In the next line there is a string of length  N ,describe the  DNA  sequence.

In the third line there is a string of length  N ,describe the  RNA  sequence.

1T10 , 1N100
 

Output
For each testcase,print  YES  or  NO ,describe whether the two arrays are matched.
 

Sample Input
  
  
2 4 ACGT UGCA 4 ACGT ACGU
 

Sample Output
  
  
YES NO
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5594  5593  5592  5591  5589 
 
判断DNA跟RNA是否配对,不好意思,我高中是学霸:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char s[1100],c[1100];
int i,j,k,l,m,n;
int judge(char s,char c)
{
	if(s=='A'&&c=='U')
	return 1;
	if(s=='T'&&c=='A')
	return 1;
	if(s=='C'&&c=='G')
	return 1;
	if(s=='G'&&c=='C')
	return 1;
	return 0;
}
int main()
{
	scanf("%d",&k);
	while(k--)
	{
		int flag=1;
		scanf("%d",&l);
		scanf("%s%s",s,c);
		for(i=0;i<l;i++)
		{
			if(!judge(s[i],c[i]))
			flag=0;
		}
		if(flag)
		printf("YES\n");
		else
		printf("NO\n");
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值