ZYB's Biology
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)Total Submission(s): 428 Accepted Submission(s): 334
Problem Description
After getting
600
scores in
NOIP
ZYB(ZJ−267)
begins to work with biological questions.Now he give you a simple biological questions:
he gives you a DNA sequence and a RNA sequence,then he asks you whether the DNA sequence and the RNA sequence are
matched.
The DNA sequence is a string consisted of A,C,G,T ;The RNA sequence is a string consisted of A,C,G,U .
DNA sequence and RNA sequence are matched if and only if A matches U , T matches A , C matches G , G matches C on each position.
he gives you a DNA sequence and a RNA sequence,then he asks you whether the DNA sequence and the RNA sequence are
matched.
The DNA sequence is a string consisted of A,C,G,T ;The RNA sequence is a string consisted of A,C,G,U .
DNA sequence and RNA sequence are matched if and only if A matches U , T matches A , C matches G , G matches C on each position.
Input
In the first line there is the testcase
T
.
For each teatcase:
In the first line there is one number N .
In the next line there is a string of length N ,describe the DNA sequence.
In the third line there is a string of length N ,describe the RNA sequence.
1≤T≤10 , 1≤N≤100
For each teatcase:
In the first line there is one number N .
In the next line there is a string of length N ,describe the DNA sequence.
In the third line there is a string of length N ,describe the RNA sequence.
1≤T≤10 , 1≤N≤100
Output
For each testcase,print
YES
or
NO
,describe whether the two arrays are matched.
Sample Input
2 4 ACGT UGCA 4 ACGT ACGU
Sample Output
YES NO
Source
Recommend
判断DNA跟RNA是否配对,不好意思,我高中是学霸:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char s[1100],c[1100];
int i,j,k,l,m,n;
int judge(char s,char c)
{
if(s=='A'&&c=='U')
return 1;
if(s=='T'&&c=='A')
return 1;
if(s=='C'&&c=='G')
return 1;
if(s=='G'&&c=='C')
return 1;
return 0;
}
int main()
{
scanf("%d",&k);
while(k--)
{
int flag=1;
scanf("%d",&l);
scanf("%s%s",s,c);
for(i=0;i<l;i++)
{
if(!judge(s[i],c[i]))
flag=0;
}
if(flag)
printf("YES\n");
else
printf("NO\n");
}
}