Dating with girls(2)
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2659 Accepted Submission(s): 744
Problem Description
If you have solved the problem Dating with girls(1).I think you can solve this problem too.This problem is also about dating with girls. Now you are in a maze and the girl you want to date with is also in the maze.If you can find the girl, then you can date with the girl.Else the girl will date with other boys. What a pity!
The Maze is very strange. There are many stones in the maze. The stone will disappear at time t if t is a multiple of k(2<= k <= 10), on the other time , stones will be still there.
There are only ‘.’ or ‘#’, ’Y’, ’G’ on the map of the maze. ’.’ indicates the blank which you can move on, ‘#’ indicates stones. ’Y’ indicates the your location. ‘G’ indicates the girl's location . There is only one ‘Y’ and one ‘G’. Every seconds you can move left, right, up or down.
The Maze is very strange. There are many stones in the maze. The stone will disappear at time t if t is a multiple of k(2<= k <= 10), on the other time , stones will be still there.
There are only ‘.’ or ‘#’, ’Y’, ’G’ on the map of the maze. ’.’ indicates the blank which you can move on, ‘#’ indicates stones. ’Y’ indicates the your location. ‘G’ indicates the girl's location . There is only one ‘Y’ and one ‘G’. Every seconds you can move left, right, up or down.

Input
The first line contain an integer T. Then T cases followed. Each case begins with three integers r and c (1 <= r , c <= 100), and k(2 <=k <= 10).
The next r line is the map’s description.
The next r line is the map’s description.
Output
For each cases, if you can find the girl, output the least time in seconds, else output "Please give me another chance!".
Sample Input
1 6 6 2 ...Y.. ...#.. .#.... ...#.. ...#.. ..#G#.
Sample Output
7
Source
Recommend
两道都做出来了,该给我个女朋友了吧。
#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
struct node
{
int x;
int y;
int step;
//friend bool operator < (node a,node b)
//{
// return a.step>b.step;
//}
}start,p;
struct rool
{
int x;
int y;
}t[10000];
int i,j,k,l,m,n,vis[110][110][15],stone,num,len,ans;
int dx[]={1,0,0,-1};
int dy[]={0,-1,1,0};
char map[110][110];
int judge(int x,int y)
{
if(x<0||x>=m||y>=n||y<0)
return 0;
return 1;
}
int bfs()
{
node team;
memset(vis,0,sizeof(vis));
vis[start.x][start.y][0]=1;
queue<node > q;
while(!q.empty())
q.pop();
q.push(start);
while(!q.empty())
{
team=q.front();
team.step++;
q.pop();
for(i=0;i<4;i++)
{
p=team;
p.x+=dx[i];
p.y+=dy[i];
if(judge(p.x,p.y)==0)
continue;
if(map[p.x][p.y]!='#'&&!vis[p.x ][p.y ][p.step%stone])
{
q.push(p);
vis[p.x][p.y ][p.step%stone]=1;
}
else
{
if(p.step%stone==0&&!vis[p.x ][p.y ][p.step%stone])
{
vis[p.x][p.y ][p.step%stone]=1;
q.push(p);
}
}
if(map[p.x][p.y]=='G')
return team.step;
}
}
return -1;
}
int main()
{
scanf("%d",&k);
while(k--)
{
scanf("%d%d%d",&m,&n,&stone);
for(i=0;i<m;i++)
scanf("%s",map[i]);
len=0;
num=0;
for(i=0;i<m;i++)
for(j=0;j<n;j++)
{
if(map[i][j]=='Y')//找到 要找公主的人
{
start.x = i;
start.y = j;
}
if(map[i][j]=='#')//储存所有的石头
{
t[len].x=i;
t[len++].y=j;
}
}
start.step = 0;
ans=bfs();
if(ans<0)
printf("Please give me another chance!\n");
else
printf("%d\n",ans);
}
return 0;
}