HDOJ 题目2838 Cow Sorting(树状数组逆序对)

Cow Sorting

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2417    Accepted Submission(s): 776


Problem Description
Sherlock's N (1 ≤ N ≤ 100,000) cows are lined up to be milked in the evening. Each cow has a unique "grumpiness" level in the range 1...100,000. Since grumpy cows are more likely to damage Sherlock's milking equipment, Sherlock would like to reorder the cows in line so they are lined up in increasing order of grumpiness. During this process, the places of any two cows (necessarily adjacent) can be interchanged. Since grumpy cows are harder to move, it takes Sherlock a total of X + Y units of time to exchange two cows whose grumpiness levels are X and Y.

Please help Sherlock calculate the minimal time required to reorder the cows.
 

Input
Line 1: A single integer: N
Lines 2..N + 1: Each line contains a single integer: line i + 1 describes the grumpiness of cow i.
 

Output
Line 1: A single line with the minimal time required to reorder the cows in increasing order of grumpiness.
 

Sample Input
  
  
3 2 3 1
 

Sample Output
  
  
7
Hint
Input Details Three cows are standing in line with respective grumpiness levels 2, 3, and 1. Output Details 2 3 1 : Initial order. 2 1 3 : After interchanging cows with grumpiness 3 and 1 (time=1+3=4). 1 2 3 : After interchanging cows with grumpiness 1 and 2 (time=2+1=3).
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   3450  2227  3030  2642  2836 
分析:其实这个结果和逆序数有关,对某个位置i,如果前面比他大的有x个,那么a[i]至少要加x次 
如果后面有y个比a[i]小,那么a[i]至少要加y次,也就是说用两个树状数组来分别维护当前位置时前面有多少比他大, 后面有多少个比他小
ac代码
 
#include<stdio.h>
#include<string.h>
__int64 a[100010],b[100010],num[100010],n;
__int64 low(__int64 x)
{
	return x&(-x);
}
void add(__int64 *a,__int64 p,__int64 q)
{
	while(p<=n)
	{
		a[p]+=q;
		p+=low(p);
	}
}
__int64 sum(__int64 *a,__int64 p)
{
	__int64 ans=0;
	while(p>0)
	{
		ans+=a[p];
		p-=low(p);
	}
	return ans;
}
int main()
{
	//int n;
	while(scanf("%d",&n)!=EOF)
	{
		int i;
		__int64 ans=0;
		for(i=1;i<=n;i++)//计算前边比当前位小的数
		{
			scanf("%d",&num[i]);
			add(a,num[i],1);
			ans+=num[i]*(i-sum(a,num[i]));
		}
		for(i=n;i>0;i--)//计算后边比当前大的数
		{
			ans+=num[i]*sum(b,num[i]-1);
			add(b,num[i],1);
		}
		printf("%I64d\n",ans);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值