1426 [kuangbin带你飞]专题一 简单搜索 E

本文介绍了一个编程挑战,即给定一个正整数n,如何找到一个n的倍数m,且m的十进制表示中只包含0和1。文章提供了使用C++实现的解决方案,并附带了示例输入输出。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

E - Find The Multiple

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111

#include<queue>
#include<cstdio>
using namespace std;

int main()
{
    int n;
    while(scanf("%d",&n)&&n) {
        queue<long long>Q;
        Q.push(1);
        while(!Q.empty()) {
            long long x=Q.front();
            Q.pop();
            if(x%n==0) {
                printf("%lld\n",x);
                break;
            }
            Q.push(x*10);
            Q.push(x*10+1);
        }
    }
    return 0;
}

用c++提交T了,用G++就过了

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值