E - Find The Multiple
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
#include<queue>
#include<cstdio>
using namespace std;
int main()
{
int n;
while(scanf("%d",&n)&&n) {
queue<long long>Q;
Q.push(1);
while(!Q.empty()) {
long long x=Q.front();
Q.pop();
if(x%n==0) {
printf("%lld\n",x);
break;
}
Q.push(x*10);
Q.push(x*10+1);
}
}
return 0;
}
用c++提交T了,用G++就过了