2017杭电多校第四场 1011 Time To Get Up(模拟)HDU 6077

000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 27    Accepted Submission(s): 25


Problem Description
Little Q's clock is alarming! It's time to get up now! However, after reading the time on the clock, Little Q lies down and starts sleeping again. Well, he has  5  alarms, and it's just the first one, he can continue sleeping for a while.

Little Q's clock uses a standard 7-segment LCD display for all digits, plus two small segments for the '':'', and shows all times in a 24-hour format. The '':'' segments are on at all times.




Your job is to help Little Q read the time shown on his clock.
 

Input
The first line of the input contains an integer  T(1T1440) , denoting the number of test cases.

In each test case, there is an  7×21  ASCII image of the clock screen.

All digit segments are represented by two characters, and each colon segment is represented by one character. The character ''X'' indicates a segment that is on while ''.'' indicates anything else. See the sample input for details.
 

Output
For each test case, print a single line containing a string  t  in the format of  HH:MM , where  t(00:00t23:59) , denoting the time shown on the clock.
 

Sample Input
  
  
1 .XX...XX.....XX...XX. X..X....X......X.X..X X..X....X.X....X.X..X ......XX.....XX...XX. X..X.X....X....X.X..X X..X.X.........X.X..X .XX...XX.....XX...XX.
 

Sample Output
  
  
02:38
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   6079  6078  6077  6076  6075 
题意:读数
解题思路:就模拟。。
#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int f[10][9]={
{1,1,1,1,1,1,0},
{0,0,1,1,0,0,0},
{0,1,1,0,1,1,1},
{0,1,1,1,1,0,1},
{1,0,1,1,0,0,1},
{1,1,0,1,1,0,1},
{1,1,0,1,1,1,1},
{0,1,1,1,0,0,0},
{1,1,1,1,1,1,1},
{1,1,1,1,1,0,1}};
char c[10][25];
int pan(int a[]){
	for(int i=0;i<10;i++){
		int flag=0;
		for(int j=0;j<7;j++){
			//printf("a[%d]=%d f[%d][%d]=%d\n",j,a[j],i,j,f[i][j]);
			if(a[j]!=f[i][j]){
				flag=1;
				break;
			}
		}
		if(flag==0)return i;
	}
	return 10;
}
int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		for(int i=0;i<7;i++){
			scanf("%s",c[i]);
		}
		int h1,h2,m1,m2;
		int a[10];
		memset(a,0,sizeof(a));
		if(c[0][1]=='X'&&c[0][2]=='X')a[1]=1;
		if(c[3][1]=='X'&&c[3][2]=='X')a[6]=1;
		if(c[6][1]=='X'&&c[6][2]=='X')a[4]=1;
		if(c[1][0]=='X'&&c[2][0]=='X')a[0]=1;
		if(c[4][0]=='X'&&c[5][0]=='X')a[5]=1;
		if(c[1][3]=='X'&&c[2][3]=='X')a[2]=1;
		if(c[4][3]=='X'&&c[5][3]=='X')a[3]=1;
		//for(int i=0;i<7;i++)cout<<a[i]<<" ";
		h1=pan(a);//cout<<h1<<endl;
		memset(a,0,sizeof(a));
		if(c[0][6]=='X'&&c[0][7]=='X')a[1]=1;
		if(c[3][6]=='X'&&c[3][7]=='X')a[6]=1;
		if(c[6][6]=='X'&&c[6][7]=='X')a[4]=1;
		if(c[1][5]=='X'&&c[2][5]=='X')a[0]=1;
		if(c[4][5]=='X'&&c[5][5]=='X')a[5]=1;
		if(c[1][8]=='X'&&c[2][8]=='X')a[2]=1;
		if(c[4][8]=='X'&&c[5][8]=='X')a[3]=1;
		//for(int i=0;i<7;i++)cout<<a[i]<<" ";
		h2=pan(a);//cout<<h2<<endl;
		memset(a,0,sizeof(a));
		if(c[0][13]=='X'&&c[0][14]=='X')a[1]=1;
		if(c[3][13]=='X'&&c[3][14]=='X')a[6]=1;
		if(c[6][13]=='X'&&c[6][14]=='X')a[4]=1;
		if(c[1][12]=='X'&&c[2][12]=='X')a[0]=1;
		if(c[4][12]=='X'&&c[5][12]=='X')a[5]=1;
		if(c[1][15]=='X'&&c[2][15]=='X')a[2]=1;
		if(c[4][15]=='X'&&c[5][15]=='X')a[3]=1;
			//for(int i=0;i<7;i++)cout<<a[i]<<" ";
		m1=pan(a);//cout<<m1<<endl;
		memset(a,0,sizeof(a));
		if(c[0][18]=='X'&&c[0][19]=='X')a[1]=1;
		if(c[3][18]=='X'&&c[3][19]=='X')a[6]=1;
		if(c[6][18]=='X'&&c[6][19]=='X')a[4]=1;
		if(c[1][17]=='X'&&c[2][17]=='X')a[0]=1;
		if(c[4][17]=='X'&&c[5][17]=='X')a[5]=1;
		if(c[1][20]=='X'&&c[2][20]=='X')a[2]=1;
		if(c[4][20]=='X'&&c[5][20]=='X')a[3]=1;
		m2=pan(a);
		printf("%d%d:%d%d\n",h1,h2,m1,m2);
	}
	return 0;
}




 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值