POJ 2192 Zipper(字符串)

Zipper
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 18632
Accepted: 6638

Description

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order. 

For example, consider forming "tcraete" from "cat" and "tree": 

String A: cat 
String B: tree 
String C: tcraete 

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree": 

String A: cat 
String B: tree 
String C: catrtee 

Finally, notice that it is impossible to form "cttaree" from "cat" and "tree". 

Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line. 

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive. 

Output

For each data set, print: 

Data set n: yes 

if the third string can be formed from the first two, or 

Data set n: no 

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example. 

Sample Input

3
cat tree tcraete
cat tree catrtee
cat tree cttaree

Sample Output

Data set 1: yes
Data set 2: yes
Data set 3: no

Source

题目大意:
前两串字符串是否可以组合成第三个字符串
解题思路:
一开始我觉得求字符串1和字符串3的最长公共子序列长度,如果最长公共子序列的长度等于字符串1的长度,且字符串2和字符串3的最长公共子序列的长度等于字符串2的长度,那么结果就是YES。
但是这个想法是错的。
验证想法错误的输入:   a a ac
所以这道题就老老实实的用普通动规做就好了。。。
dp[i][j]表示A中前i个字符与B中前j个字符是否能组成C中的前 (i+j) 个字符,然后随便转移一下就可以了
AC代码
#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
char a[205],b[205],c[405];
int dp[205][205];
int main(){
	  int t;
	  scanf("%d",&t);
	  for(int k=1;k<=t;k++){
	  	scanf("%s%s%s",a,b,c);
	  	int len1=strlen(a);
	  	int len2=strlen(b);
	  	memset(dp,0,sizeof(dp));
	  	dp[0][0]=1;  
         for(int i =0;i<=len1;i++)  
             for(int j = 0;j<=len2;j++)  
             {  
                 if(i>0 && dp[i-1][j]==1 && c[i+j-1]==a[i-1])  
                     dp[i][j]=1;  
                 if(j>0 && dp[i][j-1]==1 && c[i+j-1]==b[j-1])  
                     dp[i][j]=1;  
             }  
	  	printf("Data set %d: %s\n",k,dp[len1][len2]?"yes":"no");  
	  }
	  return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值