最小树形图

Transfer water

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 3893    Accepted Submission(s): 1397


Problem Description
XiaoA lives in a village. Last year flood rained the village. So they decide to move the whole village to the mountain nearby this year. There is no spring in the mountain, so each household could only dig a well or build a water line from other household. If the household decide to dig a well, the money for the well is the height of their house multiplies X dollar per meter. If the household decide to build a water line from other household, and if the height of which supply water is not lower than the one which get water, the money of one water line is the Manhattan distance of the two households multiplies Y dollar per meter. Or if the height of which supply water is lower than the one which get water, a water pump is needed except the water line. Z dollar should be paid for one water pump. In addition,therelation of the households must be considered. Some households may do not allow some other households build a water line from there house. Now given the 3‐dimensional position (a, b, c) of every household the c of which means height, can you calculate the minimal money the whole village need so that every household has water, or tell the leader if it can’t be done.
 

Input
Multiple cases.
First line of each case contains 4 integers n (1<=n<=1000), the number of the households, X (1<=X<=1000), Y (1<=Y<=1000), Z (1<=Z<=1000).
Each of the next n lines contains 3 integers a, b, c means the position of the i‐th households, none of them will exceeded 1000.
Then next n lines describe the relation between the households. The n+i+1‐th line describes the relation of the i‐th household. The line will begin with an integer k, and the next k integers are the household numbers that can build a water line from the i‐th household.
If n=X=Y=Z=0, the input ends, and no output for that.
 

Output
One integer in one line for each case, the minimal money the whole village need so that every household has water. If the plan does not exist, print “poor XiaoA” in one line.
 

Sample Input
  
  
2 10 20 30 1 3 2 2 4 1 1 2 2 1 2 0 0 0 0
 

Sample Output
  
  
30
Hint
In 3‐dimensional space Manhattan distance of point A (x1, y1, z1) and B(x2, y2, z2) is |x2‐x1|+|y2‐y1|+|z2‐z1|.
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
using namespace std;
const int maxn = 1005;
const int maxe = 1000000;
const int inf = 0x7fffffff;
struct node{
   int u, v, cost;
}edge[maxe];
struct point{
   int x, y, h;
}p[maxn];
int x, y, z;
int pre[maxn], ind[maxn], id[maxn], vis[maxn];

int get_p(int u, int v)
{
    int cost = 0;
    cost += (abs(p[u].x-p[v].x)+abs(p[u].y-p[v].y)+abs(p[u].h-p[v].h))*y;
    if (p[u].h < p[v].h) cost += z;
    return cost;
}

int zhuliu(int root, int n, int m)
{
    int res = 0, idx, s, t;
    while (true) {
        for (int i = 0; i < n; i ++) ind[i] = inf;
        for (int i = 0; i < m; i ++) {
            s = edge[i].u;
            t = edge[i].v;
            if (edge[i].cost < ind[t] && s != t) {
                ind[t] = edge[i].cost;
                pre[t] = s;
            }
        }
        ind[root] = 0;
        for (int i = 0; i < n; i ++) if (ind[i] == inf) return -1;
        idx = 0;
        for (int i = 0; i < n; i ++) vis[i] = -1, id[i] = -1;
        for (int i = 0; i < n; i ++) {
            res += ind[i];
            s = i;
            while (vis[s] != i && id[s] == -1 && s != root) {
                vis[s] = i;
                s = pre[s];
            }
            if (s != root && id[s] == -1) {
                for (t = pre[s]; t != s; t = pre[t]) {
                    id[t] = idx;
                }
                id[t] = idx++;
            }
        }
        //cout <<"res="<<res<<endl;
        if (idx == 0) break;
        for (int i = 0; i < n; i ++) if (id[i]== -1) id[i] = idx++;
        for (int i = 0; i < m; i ++) {
            t = edge[i].v;
            edge[i].u = id[edge[i].u];
            edge[i].v = id[edge[i].v];
            if (edge[i].u != edge[i].v) {
                edge[i].cost -= ind[t];
            }
        }
        n = idx;
        root = id[root];
    }
    return res;
}
int main() {
   int n, num;
   while (scanf("%d%d%d%d", &n, &x, &y, &z), x+y+z+n) {
     for (int i = 1; i <= n; i ++) {
        scanf("%d%d%d", &p[i].x, &p[i].y, &p[i].h);
     }
     int temp, u, v;
     num = 0;
     for (int i = 1; i <= n; i ++) {
        scanf("%d", &temp);
        for (int j = 1; j <= temp; j ++) {
            scanf("%d", &v);
            if (u != i) {
                edge[num].u = i;
                edge[num].v = v;
                edge[num].cost = get_p(i, v);
                num ++;
            }
        }
     }
     for (int i = 1; i <= n; i ++) {
        edge[num].u = 0;
        edge[num].v = i;
        edge[num].cost = (p[i].h)*x;
        num ++;
     }
     int ans = zhuliu(0, n+1, num);
     if (ans == -1) printf("poor XiaoA\n");
     else
        printf("%d\n", ans);
   }
return 0;
}



《餐馆点餐管理系统——基于Java和MySQL的课程设计解析》 在信息技术日益发达的今天,餐饮行业的数字化管理已经成为一种趋势。本次课程设计的主题是“餐馆点餐管理系统”,它结合了编程语言Java和数据库管理系统MySQL,旨在帮助初学者理解如何构建一个实际的、具有基本功能的餐饮管理软件。下面,我们将深入探讨这个系统的实现细节及其所涉及的关键知识点。 我们要关注的是数据库设计。在“res_db.sql”文件中,我们可以看到数据库的结构,可能包括菜品表、订单表、顾客信息表等。在MySQL中,我们需要创建这些表格并定义相应的字段,如菜品ID、名称、价格、库存等。此外,还要设置主键、外键来保证数据的一致性和完整性。例如,菜品ID作为主键,确保每个菜品的唯一性;订单表中的顾客ID和菜品ID则作为外键,与顾客信息表和菜品表关联,形成数据间的联系。 接下来,我们来看Java部分。在这个系统中,Java主要负责前端界面的展示和后端逻辑的处理。使用Java Swing或JavaFX库可以创建用户友好的图形用户界面(GUI),让顾客能够方便地浏览菜单、下单。同时,Java还负责与MySQL数据库进行交互,通过JDBC(Java Database Connectivity)API实现数据的增删查改操作。在程序中,我们需要编写SQL语句,比如INSERT用于添加新的菜品信息,SELECT用于查询所有菜品,UPDATE用于更新菜品的价格,DELETE用于删除不再提供的菜品。 在系统设计中,我们还需要考虑一些关键功能的实现。例如,“新增菜品和价格”的功能,需要用户输入菜品信息,然后通过Java程序将这些信息存储到数据库中。在显示所有菜品的功能上,程序需要从数据库获取所有菜品数据,然后在界面上动态生成列表或者表格展示。同时,为了提高用户体验,可能还需要实现搜索和排序功能,允许用户根据菜品名称或价格进行筛选。 另外,安全性也是系统设计的重要一环。在连接数据库时,要避免SQL注入攻击,可以通过预编译的PreparedStatement对象来执行SQL命令。对于用户输入的数据,需要进行验证和过滤,防止非法字符和异常值。 这个“餐馆点餐管理系统”项目涵盖了Java编程、数据库设计与管理、用户界面设计等多个方面,是一个很好的学习实践平台。通过这个项目,初学者不仅可以提升编程技能,还能对数据库管理和软件工程有更深入的理解。在实际开发过程中,还会遇到调试、测试、优化等挑战,这些都是成长为专业开发者不可或缺的经验积累
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值