HDU 2736 Surprising Strings

C - Surprising Strings
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue of Scientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*

Sample Output

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.
 
   
 
   
 
   
 
   
 
   
 
   
 
   
 
   
本来这个题啥也看不懂,本来想放弃了,非常感谢岩兄给非常清楚地讲解了题目,才给了我AC这题的机会!!!!
感谢岩兄...................
    
    
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<stdlib.h>
#include<map>
#include<string>

using namespace std;

int main()
{
    char a[11000],i,j;
    while(scanf("%s",a)!=EOF)
    {
        //printf("        %s\n",a);
        if(a[0] == '*')
        {
            break;
        }
        map<string,int>::iterator it;
         int k;
         k = strlen(a);
        if(k == 1 || k == 2)
        {
            printf("%s is surprising.\n",a);
        }
        else
        {
            //printf("--------%s\n",a);
            int count;
            int kk = k - 1;
            int t = 0;
            while(kk--)
            {
                count = 0;
                map<string,int>p;
                 p.clear();
                for(i=0;i+t+1<k;i++)
                {
                    string pp;
                    pp = pp + a[i];
                    pp = pp + a[i+t+1];
                    p[pp]++;
                }
                for(it=p.begin();it!=p.end();it++)
                {
                    if(it->second!=1)
                    {
                        count = 1;
                        break;
                    }
                }
                if(count == 1)
                {
                    break;
                }
                t++;
            }
            if(count == 0)
            {
                printf("%s is surprising.\n",a);
            }
            else
            {
                printf("%s is NOT surprising.\n",a);
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

叶孤心丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值