题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2044点击打开链接
一只小蜜蜂...
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 77277 Accepted Submission(s): 27812
Problem Description
有一只经过训练的蜜蜂只能爬向右侧相邻的蜂房,不能反向爬行。请编程计算蜜蜂从蜂房a爬到蜂房b的可能路线数。
其中,蜂房的结构如下所示。
其中,蜂房的结构如下所示。

Input
输入数据的第一行是一个整数N,表示测试实例的个数,然后是N 行数据,每行包含两个整数a和b(0<a<b<50)。
Output
对于每个测试实例,请输出蜜蜂从蜂房a爬到蜂房b的可能路线数,每个实例的输出占一行。
Sample Input
2 1 2 3 6
Sample Output
1 3
每个房间就是前两个房间的路径延伸 相加即可
注意longlong
#include <iostream>
#include <queue>
#include <stdio.h>
#include <stdlib.h>
#include <stack>
#include <limits>
#include <string>
#include <string.h>
#include <vector>
#include <set>
#include <map>
#include <algorithm>
#include <math.h>
using namespace std;
int main()
{
long long int a[60];
a[0]=0;
a[1]=1;
a[2]=1;
for(int i=3;i<50;i++)
a[i]=a[i-1]+a[i-2];
int mid;
scanf("%d",&mid);
for(int i=0;i<mid;i++)
{
int m,mm;
scanf("%d%d",&m,&mm);
printf("%lld\n",a[mm-m+1]);
}
}