TOYS
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 9011 | Accepted: 4284 |
Description
Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.
John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.
John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.
Input
The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.
Output
The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.
Sample Input
5 6 0 10 60 0 3 1 4 3 6 8 10 10 15 30 1 5 2 1 2 8 5 5 40 10 7 9 4 10 0 10 100 0 20 20 40 40 60 60 80 80 5 10 15 10 25 10 35 10 45 10 55 10 65 10 75 10 85 10 95 10 0
Sample Output
0: 2 1: 1 2: 1 3: 1 4: 0 5: 1 0: 2 1: 2 2: 2 3: 2 4: 2
Hint
As the example illustrates, toys that fall on the boundary of the box are "in" the box.
题目大意:将一个二维平面取出一个矩形来,划分成若干块,如图所示。然后给你若干个坐标,问你每个区域聚集了多少个坐标并输出。
想法:还是很简单的叉积运算,对于一个划分区域的两个点和给定的某个坐标进行叉积运算,如果在线的下方叉积小于0,直到出现大于等于0的情况记录cnt数组++。优化可以使用二分查找,时间复杂度O(n*lgm),不过直接查找也能过。大部分代码是模板,cross()为计算叉积。
题目大意:将一个二维平面取出一个矩形来,划分成若干块,如图所示。然后给你若干个坐标,问你每个区域聚集了多少个坐标并输出。
想法:还是很简单的叉积运算,对于一个划分区域的两个点和给定的某个坐标进行叉积运算,如果在线的下方叉积小于0,直到出现大于等于0的情况记录cnt数组++。优化可以使用二分查找,时间复杂度O(n*lgm),不过直接查找也能过。大部分代码是模板,cross()为计算叉积。
#include <cstdio>
#include <cstring>
#include<vector>
#include <algorithm>
#include <iostream>
#include <climits>
#include <numeric>
#include<cmath>
#define foreach(e,x) for(__typeof(x.begin()) e=x.begin();e!=x.end();++e)
#define REP(i,n) for(int i=0;i<n;++i)
using namespace std;
const double EPS = 1e-8;
inline int sign(double a)
{
return a < -EPS ? -1 : a > EPS;
}
struct Point
{
double x, y;
Point()
{
}
Point(double _x, double _y) :
x(_x), y(_y)
{
}
Point operator+(const Point&p) const
{
return Point(x + p.x, y + p.y);
}
Point operator-(const Point&p) const
{
return Point(x - p.x, y - p.y);
}
Point operator*(double d) const
{
return Point(x * d, y * d);
}
Point operator/(double d) const
{
return Point(x / d, y / d);
}
bool operator<(const Point&p) const
{
int c = sign(x - p.x);
if (c)
return c == -1;
return sign(y - p.y) == -1;
}
double dot(const Point&p) const
{
return x * p.x + y * p.y;
}
double det(const Point&p) const
{
return x * p.y - y * p.x;
}
double alpha() const
{
return atan2(y, x);
}
double distTo(const Point&p) const
{
double dx = x - p.x, dy = y - p.y;
return hypot(dx, dy);
}
double alphaTo(const Point&p) const
{
double dx = x - p.x, dy = y - p.y;
return atan2(dy, dx);
}
void read()
{
scanf("%lf%lf", &x, &y);
}
double abs()
{
return hypot(x, y);
}
double abs2()
{
return x * x + y * y;
}
void write()
{
cout << "(" << x << "," << y << ")" << endl;
}
};
#define cross(p1,p2,p3) ((p2.x-p1.x)*(p3.y-p1.y)-(p3.x-p1.x)*(p2.y-p1.y))
#define crossOp(p1,p2,p3) sign(cross(p1,p2,p3))
Point isSS(Point p1, Point p2, Point q1, Point q2) //可求p1,p2 直线与q1,q2的焦点。。不过不确定
{
double a1 = cross(q1,q2,p1), a2 = -cross(q1,q2,p2);
Point temp;
temp.x=sign((p1.x*a2+p2.x*a1)/(a1+a2))==0?0:(p1.x*a2+p2.x*a1)/(a1+a2);
temp.y=sign((p1.y*a2+p2.y*a1)/(a1+a2))==0?0:(p1.y*a2+p2.y*a1)/(a1+a2);
return temp;
}
struct Border
{
Point p1, p2;
long double alpha;
void setAlpha()
{
alpha = atan2(p2.y - p1.y, p2.x - p1.x);
}
void read()
{
p1.read();
p2.read();
setAlpha();
}
};
int main()
{
int n, m, x1, y1, x2, y2;
int t1, t2;
Point a;
Border line[5001];
int cnt[5002];
while (scanf ("%d", &m) && m)
{
scanf ("%d%d%d%d%d", &n, &x1, &y1, &x2, &y2);
for (int i = 0; i < m; i++)
{
scanf ("%d%d", &t1, &t2);
line[i].p1.x = t1;
line[i].p1.y = y1;
line[i].p2.x = t2;
line[i].p2.y = y2;
}
int flag=0;
memset(cnt, 0, sizeof (cnt));
for(int i=1; i<=n; i++)
{
Point toy;
toy.read();
flag=0;
for(int j=0; j<m; j++)
{
if(crossOp(line[j].p1,toy,line[j].p2)>=0)
{
flag=1;
cnt[j]++;
break;
}
} if(flag==0)
cnt[m]++;
}
for (int i=0; i <=m; i++)
printf ("%d: %d\n",i,cnt[i]);
printf("\n");
}
return 0;
}