1046. Shortest Distance (20)
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.
Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
Sample Input:
5 1 2 4 14 9 3 1 3 2 5 4 1
Sample Output:
3 10 7
#include<iostream>
#include<fstream>
#include<string>
#include<algorithm>
#include<vector>
#include<cmath>
using namespace std;
#define inf 10000000
int main()
{
//ifstream fin("Text.txt");
int N,i,j;
cin >> N;
vector<int>dis(N,0);
int sum = 0,tmp;
for (i = 1; i < N; i++)
{
cin >> tmp;
sum += tmp;
dis[i] = sum;
}
cin >> tmp;
sum += tmp;
int M,k;
char c;
cin >> M;
for (k = 0; k < M; k++)
{
cin >> i >> j;
tmp = abs(dis[i - 1] - dis[j - 1]);
cout << min(tmp, sum - tmp) << endl;
}
return 0;
}