1020. Tree Traversals (25)
Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:7 2 3 1 5 7 6 4 1 2 3 4 5 6 7Sample Output:
#include<iostream>
#include<fstream>
#include<vector>
#include<queue>
using namespace std;
typedef struct NODE* PtrN;
struct NODE
{
int root;
PtrN left;
PtrN right;
//NODE(): left(NULL), right(NULL) {};
};
int* postorder;
int* inorder;
int Findroot(int begin, int end, int data)
{
int i;
for (i = begin; i <= end; i++)
if (inorder[i] == data)break;
return i;
}
int Findmid(int postbegin, int postend, int begin, int end)
{
int i,j,flag = 0;
for ( i = postbegin; i <= postend; i++)
{
flag = 0;
for (j = begin; j <= end; j++)
{
if (postorder[i] == inorder[j])
{
flag = 1;
break;
}
}
if (flag == 0)break;
}
return i - 1;
}
PtrN BuildTree(int postbegin, int postend, int inbegin, int inend)
{
if (postbegin > postend || inbegin > inend)return NULL;
PtrN R=(PtrN)malloc(sizeof(struct NODE));
R->root = postorder[postend];
int NLpostbegin, NLpostend, NLinbegin, NLinend,
NRpostbegin, NRpostend, NRinbegin, NRinend;
int root = Findroot(inbegin, inend, postorder[postend]);
int mid = Findmid(postbegin, postend,inbegin, root-1);
NLpostbegin = postbegin; NLpostend = mid;
NLinbegin = inbegin; NLinend = root - 1;
NRpostbegin = mid + 1; NRpostend = postend-1;
NRinbegin = root + 1; NRinend = inend;
R->left = BuildTree(NLpostbegin, NLpostend, NLinbegin, NLinend);
R->right = BuildTree(NRpostbegin, NRpostend, NRinbegin, NRinend);
return R;
}
int main()
{
int N,i;
cin >> N;
postorder = new int[N];
inorder = new int[N];
for (i = 0; i < N; i++)
cin >> postorder[i];
for (i = 0; i < N; i++)
cin >> inorder[i];
PtrN ROOT;
ROOT = BuildTree(0, N-1, 0, N-1);
queue<PtrN>que;
PtrN head;
que.push(ROOT);
while (!que.empty())
{
head = que.front();
que.pop();
if (head == ROOT)
cout << head->root;
else
cout << " "<<head->root ;
if (head->left != NULL)
que.push(head->left);
if (head->right != NULL)
que.push(head->right);
}
return 0;
}