Problem Description
Farey序列是一个这样的序列:其第一级序列定义为(0/1,1/1),这一序列扩展到第二级形成序列(0/1,1/2,1/1),扩展到第三极形成序列(0/1,1/3,1/2,2/3,1/1),扩展到第四级则形成序列(0/1,1/4,1/3,1/2,2/3,3/4,1/1)。以后在每一级n,如果上一级的任何两个相邻分数a/c与b/d满足(c+d)<=n,就将一个新的分数(a+b)/(c+d)插入在两个分数之间。对于给定的n值,依次输出其第n级序列所包含的每一个分数。
Input
输入一个整数n(0<n<=100)
Output
依次输出第n级序列所包含的每一个分数,每行输出10个分数,同一行的两个相邻分数间隔一个制表符的距离。
Example Input
6
Example Output
0/1 1/6 1/5 1/4 1/3 2/5 1/2 3/5 2/3 3/4 4/5 5/6 1/1
Hint
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
struct node
{
int mu;
int zi;
struct node *next;
}*head;
void get(int m)
{
struct node *p,*q,*t;
int i;
head=(struct node *)malloc(sizeof(struct node));
head->next=NULL;
q=head;
q->next=NULL;
p=(struct node *)malloc(sizeof(struct node));
p->mu=1;p->zi=0;
q->next=p;
p->next=NULL;
q=p;
p=(struct node *)malloc(sizeof(struct node));
p->mu=1;p->zi=1;
q->next=p;
p->next=NULL;
q=p;
for(i=1;i<=m;i++)
{
q=head->next;
while(q->next)
{
t=q->next;
if(t->mu+q->mu<=i)
{
p=(struct node*)malloc(sizeof(struct node));
p->mu=t->mu+q->mu;
p->zi=t->zi+q->zi;
q->next=p;
p->next=t;
}
q=q->next;
}
}
}
void pt()
{
struct node *q;
int jishu=0;
q=head->next;
while(q!=NULL)
{
jishu++;
if(q->next!=NULL)
{
printf("%d/%d",q->zi,q->mu);
if(jishu%10==0) printf("\n");
else printf("\t");
}
else printf("%d/%d\n",q->zi,q->mu);
q=q->next;
}
}
int main()
{
int n,m;
scanf("%d",&n);
get(n);
pt();
return 0;
}