A Walk Through the Forest
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 15 Accepted Submission(s) : 9
Problem Description
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.
Input
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.
Output
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647
Sample Input
5 6 1 3 2 1 4 2 3 4 3 1 5 12 4 2 34 5 2 24 7 8 1 3 1 1 4 1 3 7 1 7 4 1 7 5 1 6 7 1 5 2 1 6 2 1 0
Sample Output
2 4
题意:从一个点到另一个点的有多少条最短路
思路:先用dij求出一个最短路 作为比较的值 然后再用dfs进行记忆化搜索找到所有的最短路
代码:
#include<iostream>
#include<cstdio>
#include<string.h>
#define N 2000
#define INF 2000000000
using namespace std;
int map[N][N],dir[N],vis[N],d[N],p[N];
void dijkstra(int s,int n)
{
int i,j,k,min;
for(i=1;i<=n;i++)
{
dir[i]=map[s][i];
}
memset(vis,false,sizeof(vis));
d[s]=0;
vis[s]=true;
for(i=1;i<n;i++)//注意不是小于等于
{
min=INF;
for(j=1;j<=n;j++)
{
if(!vis[j]&&min>dir[j])
{
min=dir[j];
k=j;
}
}
d[k]=min;
vis[k]=true;
for(j=1;j<=n;j++)
{
if(!vis[j]&&dir[j]>map[k][j]+d[k])
dir[j]=map[k][j]+d[k];
}
}
}
int DFS(int s,int n)
{
if(p[s]) return p[s];
if(s==2) return 1;
int i,sum=0;
for(i=1;i<=n;i++)
{
if(map[s][i]<INF&&d[s]>d[i])
{
if(p[i])
sum=sum+p[i];
else
sum=sum+DFS(i,n);
}
}
sum=sum+p[s];
p[s]=sum;
return p[s];
}
/*
int DFS(int now,int n) //这个dfs记忆化搜索一直没看懂
{
if(now==2) return 1;
if(p[now]) return p[now];
for(int i=0;i<=n;i++)
{
if(dir[now]>dir[map[now][i]])
p[now]+=DFS(map[now][i],n);
}
return p[now];
}
*/
int main()
{
int i,j,n,m,u,v,w;
while(cin>>n&&n)
{
cin>>m;
memset(p,0,sizeof(p));
for(i=1;i<=n;i++)
{
for(j=1;j<=n;j++)
{
map[i][j]=INF;
}
}
for(i=0;i<m;i++)
{
cin>>u>>v>>w;
map[u][v]=map[v][u]=w;
}
dijkstra(2,n);
cout<<DFS(1,n)<<endl;
}
return 0;
}