描述
XiaoMing likes mathematics, and he is just learning how to convert numbers between different bases , but he keeps making errors since he is only 6 years old. Whenever XiaoMing converts a number to a new base and writes down the result, he always writes one of the digits wrong. For example , if he converts the number 14 into binary (i.e., base 2), the correct result should be "1110", but he might instead write down "0110" or "1111". XiaoMing never accidentally adds or deletes digits, so he might write down a number with a leading digit of " 0" if this is the digit she gets wrong. Given XiaoMing 's output when converting a number N into base 2 and base 3, please determine the correct original value of N (in base 10). (N<=10^10) You can assume N is at most 1 billion, and that there is a unique solution for N.
-
输入
-
The first line of the input contains one integers T, which is the nember of test cases (1<=T<=8)
Each test case specifies:
* Line 1: The base-2 representation of N , with one digit written incorrectly.
* Line 2: The base-3 representation of N , with one digit written incorrectly.
输出
-
For each test case generate a single line containing a single integer , the correct value of N
样例输入
-
1 1010 212
样例输出
-
14
给一个二进制数和一个三进制数各自更改其中一项最后要求转换后的数用十进制表达后相等,暴力把所有情况比较一下
#include<stdio.h>
#include<string.h>
#include<stdio.h>
#include<functional>
#include<vector>
#include<queue>
#include<math.h>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
int qh(string a)//求二进制的十进制数
{
int s=0;
int t=1;
for(int i=a.length()-1;i>=0;i--)
s=s+(a[i]-'0')*t,t=t*2;
return s;
}
int qhw(string a)求三进制的十进制数
{
int s=0;
int t=1;
for(int i=a.length()-1;i>=0;i--)
s=s+(a[i]-'0')*t,t=t*3;
return s;
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
string a,b;
cin>>a>>b;
int i,j;
int f=0;
for(int i=a.length()-1;i>=0;i--)
{
string a1=a;
if(a1[i]=='0')//更改第i位
a1[i]='1';
else
a1[i]='0';
int s1=qh(a1);
//printf("%d*\n",s1);
for(int j=b.length()-1;j>=0;j--)
{
string b1=b;
if(b1[j]=='0')
{
int s2;
b1[j]='1';
s2=qhw(b1);
//printf("%d***\n",s2);
if(s2==s1)
{
f=1;
printf("%d\n",s1);
break;
}
b1[j]='2';
s2=qhw(b1);
//printf("%d***\n",s2);
if(s2==s1)
{
f=1;
printf("%d\n",s1);
break;
}
}
else if(b1[j]=='1')
{
int s2;
b1[j]='0';
s2=qhw(b1);
//printf("%d***\n",s2);
if(s2==s1)
{
f=1;
printf("%d\n",s1);
break;
}
b1[j]='2';
s2=qhw(b1);
//printf("%d***\n",s2);
if(s2==s1)
{
f=1;
printf("%d\n",s1);
break;
}
}
else if(b1[j]=='2')
{
int s2;
b1[j]='1';
s2=qhw(b1);
//printf("%d***\n",s2);
if(s2==s1)
{
f=1;
printf("%d\n",s1);
break;
}
b1[j]='0';
s2=qhw(b1);
//printf("%d***\n",s2);
if(s2==s1)
{
f=1;
printf("%d\n",s1);
break;
}
}
}
if(f==1)
break;
}
}
}