Problem E: 函数---求三个数中的最大值

 

Problem E: 函数---求三个数中的最大值

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 409   Solved: 258
[ Submit][ Status][ Web Board]

Description

编写函数max,函数声明如下:
int max(int x,int y,int z); //求三个参数中的最大值的函数声明
在以下程序的基础上,添加max函数的定义,使程序能够正确执行。
提交时,只需要提交max函数的定义代码即可。
#include <iostream>
using namespace std;
int max(int x,int y,int z); //求三个参数中的最大值的函数声明
int main()
{
  int a,b,c;
  cin>>a>>b>>c;
  cout<<"max=";
  cout<<max(a,b,c);
  return 0;
}

Input

三个整数

Output

这三个整数中的最大值

Sample Input

3 6 4

Sample Output

max=6

HINT

提交时,只需要提交max函数的定义代码即可。

#include <iostream>
using namespace std;
int max(int x,int y,int z); //求三个参数中的最大值的函数声明
int main()
{
  int a,b,c;
  cin>>a>>b>>c;
  cout<<"max=";
  cout<<max(a,b,c);
  return 0;
}int max(int x,int y,int z)
 {
     int max;
     max=x;
     max=(y>max)?y:max;
     max=(z>max)?z:max;
     return max;
 }


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值