A + B Problem II
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 299941 Accepted Submission(s): 57818
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2 1 2 112233445566778899 998877665544332211
Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
#include <iostream>
#include <string>
using namespace std;
int main()
{
string a,b,c;
long long int n,i,j,x,y,k,m;
cin>>n;
{
for(m=1;m<=n;m++)
{
cin>>a>>b;
cout<<"Case "<<m<<":"<<endl;
cout<<a<<" + "<<b<<" = ";
x=a.size();
y=b.size();
k=0;
if(x>y)
for(i=0;i<=x;i++)c[i]='0';
else for(i=0;i<=y;i++)c[i]='0';
for(i=x-1,j=y-1;;i--,j--)
{
if(i>=0&&j>=0)
{
if(a[i]+b[j]-48<='9'){c[k]+=a[i]+b[j]-96;k++;}
else {c[k]+=a[i]+b[j]-106;k++;c[k]='1';}
}
else if(i<0&&j>=0)
{
c[k]+=b[j]-48;
if(c[k]>'9'){c[k]='0';k++;c[k]='1';}
else k++;
}
else if(j<0&&i>=0)
{
c[k]+=a[i]-48;
if(c[k]>'9'){c[k]='0';k++;c[k]='1';}
else k++;
}
else break;
}
if(c[k]!='0')cout<<c[k];
for(i=k-1;i>=0;i--)
cout<<c[i];
cout<<endl;
if(m<n)cout<<endl;
#include <string>
using namespace std;
int main()
{
string a,b,c;
long long int n,i,j,x,y,k,m;
cin>>n;
{
for(m=1;m<=n;m++)
{
cin>>a>>b;
cout<<"Case "<<m<<":"<<endl;
cout<<a<<" + "<<b<<" = ";
x=a.size();
y=b.size();
k=0;
if(x>y)
for(i=0;i<=x;i++)c[i]='0';
else for(i=0;i<=y;i++)c[i]='0';
for(i=x-1,j=y-1;;i--,j--)
{
if(i>=0&&j>=0)
{
if(a[i]+b[j]-48<='9'){c[k]+=a[i]+b[j]-96;k++;}
else {c[k]+=a[i]+b[j]-106;k++;c[k]='1';}
}
else if(i<0&&j>=0)
{
c[k]+=b[j]-48;
if(c[k]>'9'){c[k]='0';k++;c[k]='1';}
else k++;
}
else if(j<0&&i>=0)
{
c[k]+=a[i]-48;
if(c[k]>'9'){c[k]='0';k++;c[k]='1';}
else k++;
}
else break;
}
if(c[k]!='0')cout<<c[k];
for(i=k-1;i>=0;i--)
cout<<c[i];
cout<<endl;
if(m<n)cout<<endl;
}
}
return 0;
}
}
return 0;
}
最简单的大数问题之一,没什莫可说的,主要是字符数组处理