[POJ] 3714 -> Raid

本文介绍了一种解决最近点对问题的方法,通过使用分治法和一种简单的暴力加剪枝算法来找出N个核能电站与N个特工之间的最短距离。包括问题背景、输入输出格式及样例。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Raid
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 8937 Accepted: 2694

Description

After successive failures in the battles against the Union, the Empire retreated to its last stronghold. Depending on its powerful defense system, the Empire repelled the six waves of Union's attack. After several sleepless nights of thinking, Arthur, General of the Union, noticed that the only weakness of the defense system was its energy supply. The system was charged by N nuclear power stations and breaking down any of them would disable the system.

The general soon started a raid to the stations by N special agents who were paradroped into the stronghold. Unfortunately they failed to land at the expected positions due to the attack by the Empire Air Force. As an experienced general, Arthur soon realized that he needed to rearrange the plan. The first thing he wants to know now is that which agent is the nearest to any power station. Could you, the chief officer, help the general to calculate the minimum distance between an agent and a station?

Input

The first line is a integer T representing the number of test cases.
Each test case begins with an integer N (1 ≤ N ≤ 100000).
The next N lines describe the positions of the stations. Each line consists of two integers X (0 ≤ X ≤ 1000000000) and Y (0 ≤ Y ≤ 1000000000) indicating the positions of the station.
The next following N lines describe the positions of the agents. Each line consists of two integers X (0 ≤ X ≤ 1000000000) and Y (0 ≤ Y ≤ 1000000000) indicating the positions of the agent.  

Output

For each test case output the minimum distance with precision of three decimal placed in a separate line.

Sample Input

2
4
0 0
0 1
1 0
1 1
2 2
2 3
3 2
3 3
4
0 0
0 0
0 0
0 0
0 0
0 0
0 0
0 0

Sample Output

1.414
0.000
 
解题思路:
最近点对问题,可以用《算法导论》上的分治法求解
这里给一种简单的暴力+剪枝算法
 
Code:
#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;

struct Point{
	double x, y;
	bool isStation;
};

inline double dist(Point& pt1, Point& pt2){
	double dx = pt1.x - pt2.x;
	double dy = pt1.y - pt2.y;
	return sqrt(dx*dx + dy*dy);
}

bool cmp(Point& pt1, Point& pt2){
	if (pt1.x == pt2.x) return pt1.y < pt2.y;
	return pt1.x < pt2.x;
}

Point points[200004];

int main(){
	int t, n;
	double x, y;
	cin >> t;
	while (t--){
		cin >> n;
		for (int i = 0; i < 2 * n; i++){
			cin >> points[i].x >> points[i].y;
			if (i < n) points[i].isStation = true;
			else points[i].isStation = false;
		}
		sort(points, points+2*n, cmp);
		double min = dist(points[0], points[n]);
		for (int i = 0; i < 2 * n; ++i){
			for (int j = i + 1; j < 2 * n; ++j){
				if (points[i].isStation == points[j].isStation) continue;
				double distance = dist(points[i], points[j]);
				if (distance < min) min = distance;
				if ((points[j].x - points[i].x) >= min) break;
			}
		}
		printf("%.3f\n", min);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值