HDOj 5918 Sequence I【KMP】

Sequence I

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1226    Accepted Submission(s): 466


Problem Description
Mr. Frog has two sequences a1,a2,,an and b1,b2,,bm and a number p. He wants to know the number of positions q such that sequence b1,b2,,bm is exactly the sequence aq,aq+p,aq+2p,,aq+(m1)p where q+(m1)pn and q1 .
 


Input
The first line contains only one integer T100 , which indicates the number of test cases.

Each test case contains three lines.

The first line contains three space-separated integers 1n106,1m106 and 1p106 .

The second line contains n integers a1,a2,,an(1ai109) .

the third line contains m integers b1,b2,,bm(1bi109) .
 


Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the number of valid q’s.
 


Sample Input
  
  
2 6 3 1 1 2 3 1 2 3 1 2 3 6 3 2 1 3 2 2 3 1 1 2 3
 


Sample Output
  
  
Case #1: 2 Case #2: 1
 


Source


KMP 变形 因为每隔p个 所以再加一层循环只循环到p即可


#include <iostream>
#include<cstdio>
#include<cstring>
#define maxn 1000010
using namespace std;
int a[maxn],b[maxn];
int n,m,p,ans,nextp[maxn];
void getnextp(){
    int i=0,j=-1;
    nextp[i]=j;
    while(i<m){
        if(j==-1||b[i]==b[j]){
            i++,j++;
            nextp[i]=j;
        }
        else
            j=nextp[j];
    }
}
void kmp(int start){
    int i=start,j=0;
    while(i<n){
        if(j==-1||a[i]==b[j])
            i+=p,j++;
        else
            j=nextp[j];
        if(j==m)
            ans++,j=nextp[j];
    }
}
int main()
{
    int t,cnt=0;
    scanf("%d",&t);
    while(t--){
        ans=0;
        scanf("%d%d%d",&n,&m,&p);
        for(int i=0;i<n;++i)
            scanf("%d",&a[i]);
        for(int i=0;i<m;++i)
            scanf("%d",&b[i]);
        getnextp();
        for(int i=0;i<p;++i)
            kmp(i);
        printf("Case #%d: %d\n",++cnt,ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值