hd2899

Strange fuction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description
Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
 
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 
Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 
Sample Input
  
  
2 100 200
 
Sample Output
  
  
-74.4291 -178.8534
 
题目大意就是上面的公式,对于不同的t来说,x从0到100,问当x取什么时公式的结果最小,并输出最小结果。
 
嗯,一种是求导做的,另一种据说是三分。。。。
 
求导
#include<stdio.h>
#include<math.h>
double f(double x,double y)
{
    return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-y*x;
}
double f1(double x)
{
    return 42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        double y,i,half,l,r;
        scanf("%lf",&y);
        r=y;l=0;
        while(r-l>1e-7)
        {
            half=(l+r)/2;
            if(f1(half)<y)l=half+1e-7;
            else r=half-1e-7;
        }
        printf("%.4lf\n",f(half,y));
    }
    return 0;
} 
 
三分。。。
#include<stdio.h>
#define EPS 0.00000001
double t;

double cal(double a)
{
	return 6*a*a*a*a*a*a*a+8*a*a*a*a*a*a+7*a*a*a+5*a*a-t*a;
}

double solve()
{
	double left,right,mid,midmid;
	left=0;right=100;
	while(left+EPS<right)
	{
		mid=(left+right)/2;
		midmid=(mid+right)/2;
		if(cal(mid)<cal(midmid)) right=midmid;
		else left=mid;
	}
	return left;
}
int main()
{
	int n;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%lf",&t);
		printf("%.4lf\n",cal(solve()));
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值