CSU - 1040 Round-number 数学题

Description

Most of the time when rounding a given number, it is customary to round to some multiple of a power of 10. However, there is no reason why we cannot use another multiple to do our rounding to. For example, you could round to the nearest multiple of 7, or the nearest multiple of 3.
Given an int n and an int b, round n to the nearest value which is a multiple of b. If n is exactly halfway between two multiples of b, return the larger value.

Input

Each line has two numbers n and b,1<=n<=1000000,2<=b<=500
Output

The answer,a number per line.
Sample Input

5 10
4 10

Sample Output

10
0

题意:输出离n最近的b的倍数
分析:
1. n ≤ b
① n < b/2 → 0
② n ≥ b/2 → b
2. n > b
d = n % b
① d < b/2 → 0+n-d
② d ≥ b/2 → b+n-d

#include<cstdio>
#include<iostream>
using namespace std;
typedef long long LL;

int main() {
#ifdef _DEBUG
    freopen("data.in", "r", stdin);
#endif // _DEBUG

    int n, b;
    while (scanf("%d%d", &n, &b) == 2) {
        int d = n % b;
        int ans = n - d + ((2 * d < b) ? 0 : b);
        //注意不能写成int ans = n - d + ((d < b/2) ? 0 : b)整型变量
        printf("%d\n", ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值