Description
Most of the time when rounding a given number, it is customary to round to some multiple of a power of 10. However, there is no reason why we cannot use another multiple to do our rounding to. For example, you could round to the nearest multiple of 7, or the nearest multiple of 3.
Given an int n and an int b, round n to the nearest value which is a multiple of b. If n is exactly halfway between two multiples of b, return the larger value.
Input
Each line has two numbers n and b,1<=n<=1000000,2<=b<=500
Output
The answer,a number per line.
Sample Input
5 10
4 10
Sample Output
10
0
题意:输出离n最近的b的倍数
分析:
1. n ≤ b
① n < b/2 → 0
② n ≥ b/2 → b
2. n > b
d = n % b
① d < b/2 → 0+n-d
② d ≥ b/2 → b+n-d
#include<cstdio>
#include<iostream>
using namespace std;
typedef long long LL;
int main() {
#ifdef _DEBUG
freopen("data.in", "r", stdin);
#endif // _DEBUG
int n, b;
while (scanf("%d%d", &n, &b) == 2) {
int d = n % b;
int ans = n - d + ((2 * d < b) ? 0 : b);
//注意不能写成int ans = n - d + ((d < b/2) ? 0 : b)整型变量
printf("%d\n", ans);
}
return 0;
}