Description
ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.
Input
Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.
Output
If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.
Sample Input
2 1
0 1 10
4 0
Sample Output
10
impossible
题意:
给N个点(编号为0~N-1),M条路,求最小生成树,如果不能生成最小生成树,则输出impossible。
思路:
用Kruskal做,如果最后得不到N-1条路(不能生成最小生成树),就输出impossible,否则输出结果。
#include<cstdio>
#include<cstring>
#include<algorithm>
//#define LOCAL
using namespace std;
const int maxn = 10000 + 5;
struct node {
int a, b, c;
bool operator<(const node&u)const {
return c < u.c;
}
}kruskal[maxn];
int fa[maxn];
int find(int x) {
return fa[x] == x ? x : fa[x] = find(fa[x]);
}
int main()
{
#ifdef LOCAL
freopen("data.in", "r", stdin);
#endif // LOCAL
int n, m;
while (~scanf("%d%d", &n, &m))
{
int sum = 0, cnt = 0;
for (int i = 0; i < n; i++)
{ fa[i] = i; }
for (int i = 0; i < m; i++)
{ scanf("%d%d%d", &kruskal[i].a, &kruskal[i].b, &kruskal[i].c); }
sort(kruskal, kruskal + m);
for (int i = 0; i < m; i++) {
int ra = find(kruskal[i].a);
int rb = find(kruskal[i].b);
if (ra != rb) {
fa[rb] = ra;
sum += kruskal[i].c;
cnt++;
}
}
if (cnt == n - 1)
printf("%d\n\n", sum);
else
puts("impossible\n");
}
return 0;
}