poj2184:cow exhibition

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8
可以看做一个01背包问题,也是有几头牛,每头牛有两个属性值,并且每头牛要么被选要么不选,但是这里的背包的容量并不是固定的,可以想象成一个背包必须装满的背包问题,也就是说在初始化的时候除了容量为0的背包初始化为0,其它的都初始化为负无穷大。同时,考虑到smartness值可能为负,所以要整体加上一个值,否则数组索引为负越界。
#include <iostream>
#include<cstring>
#include<climits>
#include<algorithm>

using namespace std;

typedef struct Cow
{
    int s;
    int f;
}cow;


int main()
{
    int N;
    int i,s;
    int maxsum=0;
    int dp[200001];
    for(i=0;i<=200000;i++)//初始化的时候所有值初始化为负无穷大,这样\
        dp[i]=INT_MIN;      //表示每个容量的背包必须装满
    dp[100000]=0;

    cin>>N;
    cow *pcow=new cow[N];
    for(i=0;i<N;i++)
        cin>>pcow[i].s>>pcow[i].f;

    for(i=0;i<N;i++)
    {

        if(pcow[i].s>0)
        {
            for(s=200000;s>=pcow[i].s;s--)
                 if(dp[s-pcow[i].s]>INT_MIN)
                      dp[s]=max(dp[s],dp[s-pcow[i].s]+pcow[i].f);
        }
        else
        {
            for(s=0;s<200000+pcow[i].s;s++)
                if(dp[s-pcow[i].s]>INT_MIN)
                    dp[s]=max(dp[s],dp[s-pcow[i].s]+pcow[i].f);
        }

    }

    for(i=100000;i<=200000;i++)
    {
        if(dp[i]>=0)
            maxsum=max(maxsum,dp[i]+i-100000);

    }
    cout<<maxsum<<endl;
    delete[] pcow;
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值