题目:
Constraints
Time Limit: 1 secs, Memory Limit: 32 MB
Description
Dr lee cuts a string S into N pieces,s[1],…,s[N].
Now, Dr lee gives you these N sub-strings: s[1],…s[N]. There might be several possibilities that the string S could be. For example, if Dr. lee gives you three sub-strings {“a”,“ab”,”ac”}, the string S could be “aabac”,”aacab”,”abaac”,…
Your task is to output the lexicographically smallest S.
Input
The first line of the input is a positive integer T. T is the number of the test cases followed.
The first line of each test case is a positive integer N (1 <=N<= 8 ) which represents the number of sub-strings. After that, N lines followed. The i-th line is the i-th sub-string s[i]. Assume that the length of each sub-string is positive and less than 100.
Output
The output of each test is the lexicographically smallest S. No redundant spaces are needed.
Sample Input
13aabac
Sample Output
aabac
Problem Source
ZSUACM Team Member
思路:
要使组合的字典序最小,直觉告诉我们应该将字串集中字典序小的放在前面,而字典序大的放在后面。然而事实并没有如此简单,比如,c与ca:c的字典序比ca要小,但是若要组合的话,cca比cac要大。所以我们应该重新定义比较规则,即若a+b<b+a才判定a<b,按照这样的规则比较就可以满足题目要求了。
代码:
#include <iostream>
#include <string>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
bool cmp(const string a, const string b)
{
return a +b < b + a;
}
int main()
{
int t;
cin>>t;
while(t--)
{
vector<string>s;
int n;
cin>>n;
string temp;
while(n--)
{
cin>>temp;
s.push_back(temp);
}
sort(s.begin(),s.end(),cmp);
for(int i=0;i<s.size();i++)
cout<<s[i];
cout<<endl;
}
return 0;
}