1015 Reversible Primes (20 分)(简单题)
A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.
Now given any two positive integers N (<105 ) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.
Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.
Output Specification:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.
Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No
#include <iostream>
using namespace std;
bool isPrime(int a){
if(a==0||a==1) return false;
for(int i=2;i*i<=a;i++){
if(a%i==0) return false;
}
return true;
}
int main(){
while(1){
int n,tmp,m,sum=0;
cin>>n;
if(n<0) break;
cin>>m;
tmp=n;
while(tmp){
sum = sum*m + (tmp%m);
tmp/=m;
}
printf("%s\n",isPrime(n)&&isPrime(sum)?"Yes":"No");
}
return 0;
}