求奇数的乘积

题目链接http://acm.hdu.edu.cn/showproblem.php?pid=2006
Problem Description
给你n个整数,求他们中所有奇数的乘积。

Input
输入数据包含多个测试实例,每个测试实例占一行,每行的第一个数为n,表示本组数据一共有n个,接着是n个整数,你可以假设每组数据必定至少存在一个奇数。

Output
输出每组数中的所有奇数的乘积,对于测试实例,输出一行。

Sample Input
3 1 2 3
4 2 3 4 5

Sample Output
3
15

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<math.h>
#include<cmath>
#include<stdio.h>
using namespace std;
#define PI 3.1415927
typedef long long ll;
int main(){
	ios:: sync_with_stdio(false);
	cin.tie(0);
	cout.tie(0);
	int n,x;
	while(scanf("%d",&n)!=EOF){
		int sum=1;
		while(n--){
			scanf("%d",&x);
			if(x%2!=0)sum*=x;
		} 
		cout<<sum<<endl;
	}
	return 0;
}
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<math.h>
#include<cmath>
#include<stdio.h>
using namespace std;
#define PI 3.1415927
typedef long long ll;
int main(){
	ios:: sync_with_stdio(false);
	cin.tie(0);
	cout.tie(0);
	int n,x;
	while(scanf("%d",&n)!=EOF){
		int sum=1;
		while(n--){
			cin>>x;
			if(x%2!=0)sum*=x;
		} 
		cout<<sum<<endl;
	}
	return 0;
}

第一个代码能过第二个不行

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值