1140 Look-and-say Sequence (20 分)--PAT甲级

该程序实现了一个Look-and-Say序列的生成,输入一个数字D和一个正整数N,输出D的第N个Look-and-Say序列。Look-and-Say序列是一种字符串序列,每个后续项都是对前一项的描述,例如1变为11,11变为1211等。给定示例中,当D=18,N=4时,输出的序列是1123123111。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, …
where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1’s, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:
Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

Output Specification:
Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:
1 8
结尾无空行
Sample Output:
1123123111
结尾无空行

题目分析:后一个字符串会根据前一个字符串每个位的数量统计,构成一个新的字符串。
例如:1
第二个字符串为11:代表"1"有1个;
第三个字符串为12:代表"1"有2个;
第四个字符串为1121:代表1有1个,2有一个…

#include<iostream>
using namespace std;

int main(){
	string temp;
	int n;
	cin >> temp >> n;
	for(int i = 0; i < n - 1; i ++){
		string str = "";
		int cnt = 1;
		for(int j = 0; j < temp.size(); j ++){
			if(temp[j] == temp[j + 1]){
				cnt ++;
			}else{
				str += temp[j];
				str += char(cnt + '0');
				cnt = 1;
			}
		}
		temp = str;
	}
	cout << temp << endl;
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值