Look-and-say sequence is a sequence of integers as the following:
D, D1, D111, D113, D11231, D112213111, …
where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1’s, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.
Input Specification:
Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.
Output Specification:
Print in a line the Nth number in a look-and-say sequence of D.
Sample Input:
1 8
结尾无空行
Sample Output:
1123123111
结尾无空行
题目分析:后一个字符串会根据前一个字符串每个位的数量统计,构成一个新的字符串。
例如:1
第二个字符串为11:代表"1"有1个;
第三个字符串为12:代表"1"有2个;
第四个字符串为1121:代表1有1个,2有一个…
#include<iostream>
using namespace std;
int main(){
string temp;
int n;
cin >> temp >> n;
for(int i = 0; i < n - 1; i ++){
string str = "";
int cnt = 1;
for(int j = 0; j < temp.size(); j ++){
if(temp[j] == temp[j + 1]){
cnt ++;
}else{
str += temp[j];
str += char(cnt + '0');
cnt = 1;
}
}
temp = str;
}
cout << temp << endl;
return 0;
}