POJ 1679 The Unique MST(次小生成树)
题目
Given a connected undirected graph, tell if its minimum spanning tree is unique.
Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V’, E’), with the following properties:
- V’ = V.
- T is connected and acyclic.
Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E’) of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E’.
Input
The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.
Output
For each input, if the MST is unique, print the total cost of it, or otherwise print the string ‘Not Unique!’.
Sample Input
2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2
Sample Output
3
Not Unique!
题意
有一堆道路,现在有两个人想要删除一些道路,满足能够连通所有地方,并且的删除的道路权值和最大,已知两个人删除道路不同,如果两个人的最优解相同,说明最小生成树不唯一,次小生成树权值和等于最小生成树权值和。
思路分析
首先使用kruskal算法求出最小生成树,然后依次判断未连入最小生成树的边,已知将该边连入最小生成树时,会形成一个环,使用并查集求出该环中最大边的权值,判断去除环中最大边后,再加上连入的边,总权值是否与最小生成树的权值相等。如果相等输出Not Unique!若不等输出最小生成树的权值。
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
int n, m;
int vis[10000];
int map[10000][10000];
struct node
{
int x, y;
int sum;
int f;//标记该边是否连入。
}s[50000];//保存边
bool red(node x, node y)//定义sort排序
{
return x.sum < y.sum;
}
int bin(int x)//查找跟节点
{
while (vis[x] != x)
x = vis[x];
return x;
}
int find(int x)
{
int sum=-1;
while (vis[x] != x)
{
sum = max(sum, map[x][vis[x]]);
x = vis[x];
}
return sum;
}
int main()
{
int T;
cin >> T;
while (T--)
{
cin >> n >> m;
for (int i = 0; i < m; i++)
{
cin >> s[i].x >> s[i].y >> s[i].sum;
map[s[i].x][s[i].y] = map[s[i].y][s[i].x] = s[i].sum;
s[i].f = 0;
}
for (int i = 0; i <= n; i++)
{
vis[i] = i;
}
sort(s, s + m, red);
int sum = 0;
for (int i = 0; i < m; i++)
{
if (bin(s[i].x) != bin(s[i].y))
{
vis[s[i].y] = s[i].x;
s[i].f = 1;
sum += s[i].sum;
}
}
int t = 0;
int maxn = -1;
for (int i = 0; i < m; i++)
{
int sum2 = sum;
if (s[i].f == 0)
{
maxn = max(find(s[i].x), find(s[i].y));
sum2 -= maxn;
sum2 += s[i].sum;
if (sum2 == sum)
{
t = 1;
}
}
}
if (t == 1)
{
cout << "Not Unique!" << endl;
}
else
cout << sum << endl;
}
}